summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-net-ssleay/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-net-ssleay/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-net-ssleay/PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/abs/core/perl_modules/perl-net-ssleay/PKGBUILD b/abs/core/perl_modules/perl-net-ssleay/PKGBUILD
index efa9b59..8476265 100644
--- a/abs/core/perl_modules/perl-net-ssleay/PKGBUILD
+++ b/abs/core/perl_modules/perl-net-ssleay/PKGBUILD
@@ -1,36 +1,38 @@
-# $Id: PKGBUILD 82525 2010-06-12 20:09:39Z kevin $
+# $Id: PKGBUILD 160545 2012-06-02 10:28:03Z bluewind $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Manolis Tzanidakis
pkgname=perl-net-ssleay
_cpanname=Net-SSLeay
-pkgver=1.36
-pkgrel=3
+pkgver=1.48
+pkgrel=2
pkgdesc="Perl extension for using OpenSSL"
arch=('i686' 'x86_64')
license=('custom:BSD')
url="http://search.cpan.org/dist/${_cpanname}/"
-depends=('perl' 'openssl')
+depends=('openssl')
options=(!emptydirs)
replaces=('net-ssleay')
provides=('net-ssleay')
-source=(http://www.cpan.org/authors/id/F/FL/FLORA/${_cpanname}-${pkgver}.tar.gz)
-md5sums=('54061638720dd6a325395331c77f21d8')
+source=("http://www.cpan.org/authors/id/M/MI/MIKEM/${_cpanname}-${pkgver}.tar.gz")
+md5sums=('4e10d9da28f26732e37807820bf72af5')
build() {
cd ${srcdir}/${_cpanname}-${pkgver}
+
# install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL -- INSTALLDIRS=vendor || return 1
- make || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL -- INSTALLDIRS=vendor
+ make
}
+
package() {
cd ${srcdir}/${_cpanname}-${pkgver}
- make install DESTDIR=${pkgdir} || return 1
+
+ make install DESTDIR=${pkgdir}
# remove perllocal.pod and .packlist
find ${pkgdir} -name perllocal.pod -delete
find ${pkgdir} -name .packlist -delete
- install -D -m644 README ${pkgdir}/usr/share/licenses/${pkgname}/README
+ install -D -m644 README "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim: ts=2 sw=2 et ft=sh