summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-net-upnp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-net-upnp/PKGBUILD')
-rwxr-xr-xabs/core/perl_modules/perl-net-upnp/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-net-upnp/PKGBUILD b/abs/core/perl_modules/perl-net-upnp/PKGBUILD
new file mode 100755
index 0000000..26db326
--- /dev/null
+++ b/abs/core/perl_modules/perl-net-upnp/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=perl-net-upnp
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="Net::UPnP::AV::MediaServer - Perl extension for UPnP."
+arch=(i686 x86_64)
+url="http://search.cpan.org/~sbeck/DateManip-$pkgver/"
+depends=('perl')
+source=(http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/DateManip-$pkgver.tar.gz)
+source=http://search.cpan.org/CPAN/authors/id/S/SK/SKONNO/Net-UPnP-1.4.1.tar.gz
+build() {
+ cd $startdir/src/Net-UPnP-$pkgver
+ # Force module installation to "current" perl directories.
+ /usr/bin/perl Makefile.PL \
+ INSTALLARCHLIB=/usr/lib/perl5/current/${CARCH}-linux-thread-multi \
+ INSTALLSITELIB=/usr/lib/perl5/site_perl/current \
+ INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${CARCH}-linux-thread-multi
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+
+ # remove perllocal.pod, .packlist, and empty dirs.
+ /bin/rm -rf $startdir/pkg/usr/lib/perl5/current
+ /bin/rm -rf $startdir/pkg/usr/lib/perl5/site_perl/current/${CARCH}-linux-thread-multi
+}