summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-package-stash-xs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-package-stash-xs/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-package-stash-xs/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-package-stash-xs/PKGBUILD b/abs/core/perl_modules/perl-package-stash-xs/PKGBUILD
new file mode 100644
index 0000000..ee83389
--- /dev/null
+++ b/abs/core/perl_modules/perl-package-stash-xs/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Justin Davis <jrcd83@gmail.com>
+# $Id: PKGBUILD 71819 2012-06-02 10:31:46Z bluewind $
+
+pkgname=perl-package-stash-xs
+pkgver=0.25
+pkgrel=2
+pkgdesc="faster and more correct implementation of the Package::Stash API"
+arch=(i686 x86_64)
+license=(PerlArtistic GPL)
+options=(!emptydirs)
+depends=('perl>=5.8.1')
+makedepends=('perl-extutils-makemaker>=6.30')
+checkdepends=('perl-test-fatal' 'perl-test-simple')
+url=https://metacpan.org/release/Package-Stash-XS
+source=("http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-XS-${pkgver}.tar.gz")
+md5sums=(52ece18842c46da8fb7a4a14dea910ab)
+sha512sums=(2b539d9ba1a68c5ba681e9eabbcde4b396f66dc8dbd3b1e333286ea7ce39b93b97ec4bd97c31681720a925553b128371ce2c48f11254806aebd5de868a22b528)
+_distdir="${srcdir}/Package-Stash-XS-${pkgver}"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ cd "$_distdir"
+ make test
+ )
+}
+
+package() {
+ cd "$_distdir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: