summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-par-dist/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-par-dist/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-par-dist/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-par-dist/PKGBUILD b/abs/core/perl_modules/perl-par-dist/PKGBUILD
new file mode 100644
index 0000000..9034e91
--- /dev/null
+++ b/abs/core/perl_modules/perl-par-dist/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: TDY <tdy@gmx.com>
+# Contributor: François Charette <firmicus ατ gmx δοτ net>
+
+pkgname=perl-par-dist
+pkgver=0.49
+pkgrel=3
+pkgdesc="Perl bindings to create and manipulate PAR distributions"
+arch=('any')
+url="http://search.cpan.org/dist/PAR-Dist/"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/R/RS/RSCHUPP/PAR-Dist-$pkgver.tar.gz")
+md5sums=('bd852113974544f3c8c107ab4055cf8c')
+
+build() {
+ cd "$srcdir/PAR-Dist-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/PAR-Dist-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/PAR-Dist-$pkgver"
+ make install DESTDIR="$pkgdir"
+}