summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-params-util/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-params-util/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-params-util/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-params-util/PKGBUILD b/abs/core/perl_modules/perl-params-util/PKGBUILD
new file mode 100644
index 0000000..415ad58
--- /dev/null
+++ b/abs/core/perl_modules/perl-params-util/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Justin Davis (juster) <jrcd83@gmail.com>
+# $Id: PKGBUILD 72466 2012-06-15 00:05:46Z juster $
+
+pkgname=perl-params-util
+pkgver=1.07
+pkgrel=1
+pkgdesc='Simple, compact and correct param-checking functions'
+arch=(i686 x86_64)
+license=(PerlArtistic GPL)
+options=(!emptydirs)
+depends=('perl>=5.5.30')
+url=https://metacpan.org/release/Params-Util
+source=("http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Params-Util-$pkgver.tar.gz")
+md5sums=(02db120c0eef87aae1830cc62bdec37b)
+sha512sums=(ff471b01b33414fc5e1c68d97c21171a95d3418c33e3c45f9910cc768898690e35051506a83ad9403a200336654c14b8efc9d471c4b3fe3321047a7603d6fd56)
+_dir="$srcdir/Params-Util-$pkgver"
+
+build()
+(
+ cd "$_dir"
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ unset PERL5LIB PERL_MM_OPT
+ /usr/bin/perl Makefile.PL
+ make
+)
+
+check()
+(
+ cd "$_dir"
+ export PERL_MM_USE_DEFAULT=1
+ unset PERL5LIB
+ make test
+)
+
+package()
+(
+ cd "$_dir"
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+)
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: