summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-proc-pid-file/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-proc-pid-file/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-proc-pid-file/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-proc-pid-file/PKGBUILD b/abs/core/perl_modules/perl-proc-pid-file/PKGBUILD
new file mode 100644
index 0000000..ad69d71
--- /dev/null
+++ b/abs/core/perl_modules/perl-proc-pid-file/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Cecil H. Watson <knoppmyth@gmail.com>
+
+pkgname=perl-proc-pid-file
+_realname=Proc-PID-File
+pkgver=1.24
+pkgrel=1
+pkgdesc="Proc::PID::File a module to manage process idfiles"
+arch=(i686 x86_64)
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perlxml' 'perl>=5.10.0')
+options=('!emptydirs')
+source=(ftp://ftp.cpan.org/pub/CPAN/authors/id/E/EC/ECALDER/${_realname}-${pkgver}.tar.gz)
+md5sums=('90b636492ae72def975a9ef9cac90fda')
+
+build() {
+ cd ${startdir}/src/${_realname}-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ find ${startdir}/pkg -name '.packlist' -delete
+ find ${startdir}/pkg -name 'perllocal.pod' -delete
+}