summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-test-exception/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-test-exception/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-test-exception/PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/abs/core/perl_modules/perl-test-exception/PKGBUILD b/abs/core/perl_modules/perl-test-exception/PKGBUILD
index ccf2bc6..793ad69 100644
--- a/abs/core/perl_modules/perl-test-exception/PKGBUILD
+++ b/abs/core/perl_modules/perl-test-exception/PKGBUILD
@@ -1,26 +1,27 @@
-# This PKGBUILD was autocreated. See http://xtermin.us/archperl/ for details
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Charles Mauch <cmauch@gmail.com>
pkgname=perl-test-exception
-pkgver=0.31
-pkgrel=1
+pkgver=0.43
+pkgrel=3
pkgdesc="Perl/CPAN Module Test::Exception : Functions for testing exceptionbased code"
arch=("any")
-url="http://search.cpan.org/~adie/"
-license=("GPL" "Artistic")
-makedepends=("perl-sub-uplevel")
+url="http://search.cpan.org/dist/Test-Exception/"
+license=("GPL" "PerlArtistic")
depends=("perl-sub-uplevel")
-source=("http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Exception-$pkgver.tar.gz")
-md5sums=('adb57ca7614d15e5b307bf5e024b35a8')
+source=("http://search.cpan.org/CPAN/authors/id/E/EX/EXODIST/Test-Exception-$pkgver.tar.gz")
+md5sums=('572d355026fb0b87fc2b8c64b83cada0')
build() {
- cd $srcdir/Test-Exception-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd "$srcdir"/Test-Exception-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
+
package() {
- cd $srcdir/Test-Exception-$pkgver
- make install DESTDIR=$pkgdir
- find $pkgdir -name '.packlist' -delete
- find $pkgdir -name '*.pod' -delete
+ cd "$srcdir"/Test-Exception-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
}