summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-test-fatal/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-test-fatal/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-test-fatal/PKGBUILD63
1 files changed, 24 insertions, 39 deletions
diff --git a/abs/core/perl_modules/perl-test-fatal/PKGBUILD b/abs/core/perl_modules/perl-test-fatal/PKGBUILD
index dfae079..3309313 100644
--- a/abs/core/perl_modules/perl-test-fatal/PKGBUILD
+++ b/abs/core/perl_modules/perl-test-fatal/PKGBUILD
@@ -1,46 +1,31 @@
-# Maintainer: Justin Davis (juster) <jrcd83@gmail.com>
-# $Id: PKGBUILD 71635 2012-05-31 15:12:33Z juster $
+# $Id$
+# Maintainer: Jonathan Steel <jsteel@aur.archlinux.org>
+# Contributor: Justin Davis (juster) <jrcd83@gmail.com>
pkgname=perl-test-fatal
-pkgver=0.010
-pkgrel=1
-pkgdesc='incredibly simple helpers for testing code with exceptions'
-arch=(any)
-license=(PerlArtistic GPL)
-options=(!emptydirs)
-depends=('perl-try-tiny>=0.07')
-url=https://metacpan.org/release/Test-Fatal
-source=("http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-$pkgver.tar.gz")
-md5sums=(d8052d4160e8d999cbeb574592f26541)
-sha512sums=(24ed85a957e316f49673613295978ff4f2485f762427a8e51594221fe7601d6df3ab1d92dd5a9a8943cce42a04a3a712b781a7ae31403995a03bbf177006edf6)
-_dir="$srcdir/Test-Fatal-$pkgver"
+pkgver=0.014
+pkgrel=3
+pkgdesc="Incredibly simple helpers for testing code with exceptions"
+arch=('any')
+url="https://metacpan.org/release/Test-Fatal"
+license=('PerlArtistic' 'GPL')
+depends=('perl-try-tiny')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-$pkgver.tar.gz)
+sha1sums=('6984ef1c0aed1d2c8334e8f20818cbf269abc345')
-build()
-(
- cd "$_dir"
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
- unset PERL5LIB PERL_MM_OPT
- /usr/bin/perl Makefile.PL
+build() {
+ cd "$srcdir/Test-Fatal-$pkgver"
+ perl Makefile.PL
make
-)
+}
-check()
-(
- cd "$_dir"
- export PERL_MM_USE_DEFAULT=1
- unset PERL5LIB
+check() {
+ cd "$srcdir/Test-Fatal-$pkgver"
make test
-)
+}
-package()
-(
- cd "$_dir"
- make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-)
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et:
+package() {
+ cd "$srcdir/Test-Fatal-$pkgver"
+ make INSTALLDIRS=vendor DESTDIR="$pkgdir" install
+}