summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-test-pod/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-test-pod/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-test-pod/PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/abs/core/perl_modules/perl-test-pod/PKGBUILD b/abs/core/perl_modules/perl-test-pod/PKGBUILD
index 5adb9d1..f6e0d22 100644
--- a/abs/core/perl_modules/perl-test-pod/PKGBUILD
+++ b/abs/core/perl_modules/perl-test-pod/PKGBUILD
@@ -1,30 +1,32 @@
-# $Id: PKGBUILD 140682 2011-10-18 03:16:34Z eric $
-# Maintainer: Kevin <kevin@archlinux.org>
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Kevin <kevin@archlinux.org>
# Contributor: Firmicus <francois.archlinux.org>
pkgname=perl-test-pod
-_realname=Test-Pod
-pkgver=1.45
+pkgver=1.52
pkgrel=1
pkgdesc="Check for POD errors in files"
arch=('any')
-url="http://search.cpan.org/dist/${_realname}/"
+url="http://search.cpan.org/dist/Test-Pod/"
license=('GPL' 'PerlArtistic')
depends=('perl')
options=('!emptydirs')
-source=(http://search.cpan.org/CPAN/authors/id/D/DW/DWHEELER/${_realname}-${pkgver}.tar.gz)
-md5sums=('089c8f272931df82f6c4d11a74f04628')
+source=(http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Test-Pod-${pkgver}.tar.gz)
+sha512sums=('9b078488e1da8b907f5f3a46452aa9bfd49db61f1539d076dccebf9a8b476eaf0f539f00badc9c500b1e732a8827331b2286375924986efb990367767eeb8365')
build() {
- cd "${srcdir}/${_realname}-${pkgver}"
- perl Build.PL installdirs=vendor
- ./Build
+ cd Test-Pod-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
}
-package() {
- cd "${srcdir}/${_realname}-${pkgver}"
- ./Build install destdir="${pkgdir}"
+check() {
+ cd Test-Pod-${pkgver}
+ make test
+}
- find "${pkgdir}" -name '.packlist' -delete
- find "${pkgdir}" -name '*.pod' -delete
+package() {
+ cd Test-Pod-${pkgver}
+ make DESTDIR="${pkgdir}" install
}