summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-test-pod/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-test-pod/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-test-pod/PKGBUILD41
1 files changed, 23 insertions, 18 deletions
diff --git a/abs/core/perl_modules/perl-test-pod/PKGBUILD b/abs/core/perl_modules/perl-test-pod/PKGBUILD
index a901b02..5adb9d1 100644
--- a/abs/core/perl_modules/perl-test-pod/PKGBUILD
+++ b/abs/core/perl_modules/perl-test-pod/PKGBUILD
@@ -1,25 +1,30 @@
-#
-# Contributor: Oliver Charles <oliver.g.charles@googlemail.com>
-#
+# $Id: PKGBUILD 140682 2011-10-18 03:16:34Z eric $
+# Maintainer: Kevin <kevin@archlinux.org>
+# Contributor: Firmicus <francois.archlinux.org>
-pkgname="perl-test-pod"
-pkgver=1.26
+pkgname=perl-test-pod
+_realname=Test-Pod
+pkgver=1.45
pkgrel=1
-pkgdesc="Translate Wiki formatted text to other formats"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~petdance/Test-Pod"
-license="unknown"
-depends=('perl>=5.10.0')
+pkgdesc="Check for POD errors in files"
+arch=('any')
+url="http://search.cpan.org/dist/${_realname}/"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/P/PE/PETDANCE/Test-Pod-$pkgver.tar.gz)
-md5sums=('2f259135656ac4549b65a4f14f07b7c6')
+source=(http://search.cpan.org/CPAN/authors/id/D/DW/DWHEELER/${_realname}-${pkgver}.tar.gz)
+md5sums=('089c8f272931df82f6c4d11a74f04628')
build() {
- cd $startdir/src/Test-Pod-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make DESTDIR="$pkgdir/" install || return 1
+ cd "${srcdir}/${_realname}-${pkgver}"
+ perl Build.PL installdirs=vendor
+ ./Build
+}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ ./Build install destdir="${pkgdir}"
- find "$pkgdir" -name '.packlist' -delete
- find "$pkgdir" -name 'perllocal.pod' -delete
+ find "${pkgdir}" -name '.packlist' -delete
+ find "${pkgdir}" -name '*.pod' -delete
}