summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-try-tiny/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-try-tiny/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-try-tiny/PKGBUILD57
1 files changed, 20 insertions, 37 deletions
diff --git a/abs/core/perl_modules/perl-try-tiny/PKGBUILD b/abs/core/perl_modules/perl-try-tiny/PKGBUILD
index f70a01e..821b68b 100644
--- a/abs/core/perl_modules/perl-try-tiny/PKGBUILD
+++ b/abs/core/perl_modules/perl-try-tiny/PKGBUILD
@@ -1,49 +1,32 @@
-# Maintainer: Justin Davis <jrcd83@gmail.com>
-# $Id: PKGBUILD 57540 2011-10-30 17:10:04Z juster $
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=perl-try-tiny
-pkgver=0.11
+pkgver=0.30
pkgrel=1
-pkgdesc="minimal try/catch with proper localization of \$@"
-arch=(any)
-license=(PerlArtistic GPL)
-options=(!emptydirs)
-makedepends=('perl-extutils-makemaker')
-checkdepends=('perl-test-simple')
-url=https://metacpan.org/release/Try-Tiny
-source=("http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Try-Tiny-${pkgver}.tar.gz")
-md5sums=(4d2c8ff385ac3513edf4c042dd0eacbe)
-sha512sums=(42a98d0996e4195b1618e99080f67791ec9b09c8c4de669aafcbe75c609718d700a6831dd5a68d8f7bda563c29ce3a8495bbf548b8d38a155471875889d8c701)
-_distdir="${srcdir}/Try-Tiny-${pkgver}"
+pkgdesc="Minimal try/catch with proper localization of \$@"
+arch=('any')
+url="http://search.cpan.org/dist/Try-Tiny"
+license=('MIT')
+depends=('perl')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Try-Tiny-${pkgver}.tar.gz")
+sha512sums=('f523736ab0504ca0f7150be312e62988c4b9473a9e8469b0746dc8364945e2922c64c92e95e6c2b5792c5d6399dabea3d00aa45c065155b95519d5658a07216c')
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ cd Try-Tiny-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- cd "$_distdir"
- make test
- )
+ cd Try-Tiny-${pkgver}
+ make test
}
package() {
- cd "$_distdir"
- make DESTDIR="$pkgdir" install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd Try-Tiny-${pkgver}
+ make DESTDIR="$pkgdir" install
+ # upstream typo :/
+ install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: