summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-uri/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-uri/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-uri/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/abs/core/perl_modules/perl-uri/PKGBUILD b/abs/core/perl_modules/perl-uri/PKGBUILD
index 7f18b32..c6b5531 100644
--- a/abs/core/perl_modules/perl-uri/PKGBUILD
+++ b/abs/core/perl_modules/perl-uri/PKGBUILD
@@ -1,21 +1,22 @@
-# $Id: PKGBUILD 140684 2011-10-18 03:20:44Z eric $
-# Maintainer: eric <eric@archlinux.org>
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Manolis Tzanidakis
# Contributor: Firmicus <francois.archlinux.org>
pkgname=perl-uri
_realname=URI
-pkgver=1.59
+pkgver=1.74
pkgrel=1
pkgdesc="Uniform Resource Identifiers (absolute and relative)"
arch=('any')
url="http://search.cpan.org/dist/${_realname}/"
license=('PerlArtistic')
-depends=('perl>=5.10.0')
+depends=('perl')
+checkdepends=('perl-test-needs')
provides=('perl-uri-escape=3.30')
options=('!emptydirs')
-source=(http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/${_realname}-$pkgver.tar.gz)
-md5sums=('fecebf8fa20e2d26ea4a1649c095e96e')
+source=("http://cpan.metacpan.org/authors/id/E/ET/ETHER/${_realname}-${pkgver}.tar.gz")
+sha512sums=('b537bd09c355989a2bb1919e2c228cf189e57f993add4246fa482d8ee5ec814266c6fb3229befce2f294456ee784a819d9a54013c43a2ad41b5d8914fabf046b')
build() {
cd "${srcdir}/${_realname}-$pkgver"
@@ -24,6 +25,11 @@ build() {
make
}
+check() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make test
+}
+
package() {
cd "${srcdir}/${_realname}-$pkgver"
make install DESTDIR="${pkgdir}"