summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-uri/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-uri/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-uri/PKGBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/abs/core/perl_modules/perl-uri/PKGBUILD b/abs/core/perl_modules/perl-uri/PKGBUILD
index ec8f2c5..7f18b32 100644
--- a/abs/core/perl_modules/perl-uri/PKGBUILD
+++ b/abs/core/perl_modules/perl-uri/PKGBUILD
@@ -1,31 +1,31 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 140684 2011-10-18 03:20:44Z eric $
# Maintainer: eric <eric@archlinux.org>
# Contributor: Manolis Tzanidakis
+# Contributor: Firmicus <francois.archlinux.org>
pkgname=perl-uri
_realname=URI
-pkgver=1.35
-pkgrel=3
-pkgdesc="Perl Module: form Resource Identifiers (absolute and relative)"
-arch=(i686 x86_64)
-license=('PerlArtistic')
+pkgver=1.59
+pkgrel=1
+pkgdesc="Uniform Resource Identifiers (absolute and relative)"
+arch=('any')
url="http://search.cpan.org/dist/${_realname}/"
+license=('PerlArtistic')
depends=('perl>=5.10.0')
-options=(!emptydirs)
-source=(http://www.cpan.org/authors/id/G/GA/GAAS/${_realname}-$pkgver.tar.gz)
-replaces=('uri')
-provides=('uri')
-md5sums=('1a933b1114c41a25587ee59ba8376f7c')
+provides=('perl-uri-escape=3.30')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/${_realname}-$pkgver.tar.gz)
+md5sums=('fecebf8fa20e2d26ea4a1649c095e96e')
build() {
- cd $startdir/src/${_realname}-$pkgver
+ cd "${srcdir}/${_realname}-$pkgver"
# install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make MAN1EXT=1p MAN3EXT=3pm || return 1
- make install MAN1EXT=1p MAN3EXT=3pm DESTDIR=${startdir}/pkg || return 1
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
- # remove perllocal.pod and .packlist
- find ${startdir}/pkg -name perllocal.pod -delete
- find ${startdir}/pkg -name .packlist -delete
+package() {
+ cd "${srcdir}/${_realname}-$pkgver"
+ make install DESTDIR="${pkgdir}"
}
# vim: ts=2 sw=2 et ft=sh