summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-x10/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-x10/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-x10/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-x10/PKGBUILD b/abs/core/perl_modules/perl-x10/PKGBUILD
new file mode 100644
index 0000000..51283d5
--- /dev/null
+++ b/abs/core/perl_modules/perl-x10/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-x10
+pkgver=0.03
+pkgrel=2
+pkgdesc="X10"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~ROBF/X10"
+license=('GPL' 'PerlArtistic')
+depends=('perl-astro-suntime>=0.01' 'perl-device-serialport' 'perl-time-modules')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/R/RO/ROBF/X10-$pkgver.tar.gz)
+md5sums=('056b3d98fab545865148b948de6784c7')
+
+build() {
+ cd $startdir/src/X10-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: