summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-xml-parser/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-xml-parser/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-xml-parser/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-xml-parser/PKGBUILD b/abs/core/perl_modules/perl-xml-parser/PKGBUILD
new file mode 100644
index 0000000..c0fe960
--- /dev/null
+++ b/abs/core/perl_modules/perl-xml-parser/PKGBUILD
@@ -0,0 +1,24 @@
+# This PKGBUILD was autocreated. See http://xtermin.us/archperl/ for details
+# Maintainer: Charles Mauch <cmauch@gmail.com>
+pkgname=perl-xml-parser
+pkgver=2.34
+pkgrel=2
+pkgdesc="Perl/CPAN Module XML::Parser : Flexible fast parser with plugin styles"
+arch=("i686" "x86_64")
+url="http://search.cpan.org/MSERGEANT/XML-Parser"
+license=("GPL" "Artistic")
+source=("http://www.cpan.org/authors/id/M/MS/MSERGEANT/XML-Parser-2.34.tar.gz")
+md5sums=("84d9e0001fe01c14867256c3fe115899")
+build() {
+ cd $startdir/src/XML-Parser-2.34
+ eval `perl -V:archname`
+ /usr/bin/perl Makefile.PL \
+ INSTALLARCHLIB=/usr/lib/perl5/current/${archname} \
+ INSTALLSITELIB=/usr/lib/perl5/site_perl/current \
+ INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${archname} || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -exec rm '{}' \; && \
+ /usr/bin/find $startdir/pkg -name 'perllocal.pod' -exec rm '{}' \; && \
+ /usr/bin/find $startdir/pkg -depth -type d -empty -exec rmdir '{}' \;
+}