summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-xml-parser/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-xml-parser/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-xml-parser/PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/abs/core/perl_modules/perl-xml-parser/PKGBUILD b/abs/core/perl_modules/perl-xml-parser/PKGBUILD
index 962dc0b..3e2a9db 100644
--- a/abs/core/perl_modules/perl-xml-parser/PKGBUILD
+++ b/abs/core/perl_modules/perl-xml-parser/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 99293 2010-11-13 20:13:13Z andrea $
+# $Id: PKGBUILD 160565 2012-06-02 10:28:38Z bluewind $
# Maintainer:
# Contributor: firmicus <francois@archlinux.org>
# Contributor: dorphell <dorphell@archlinux.org>
@@ -6,29 +6,32 @@
pkgname=perl-xml-parser
_realname=XML-Parser
-pkgver=2.40
+pkgver=2.41
pkgrel=3
pkgdesc="Expat-based XML parser module for perl"
arch=('i686' 'x86_64')
license=('GPL' 'PerlArtistic')
url="http://search.cpan.org/dist/${_realname}/"
-replaces=('perlxml')
depends=('perl' 'expat')
+replaces=('perlxml')
provides=("perlxml=${pkgver}")
options=('!emptydirs')
-source=("http://search.cpan.org/CPAN/authors/id/C/CH/CHORNY/${_realname}-${pkgver}.tar.gz")
-md5sums=('c66e9adba003d0667cc40115ccd837a5')
-
-
+source=("http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/${_realname}-${pkgver}.tar.gz")
+md5sums=('c320d2ffa459e6cdc6f9f59c1185855e')
build() {
cd "${srcdir}/${_realname}-${pkgver}"
-
+
# install module in vendor directories.
perl Makefile.PL INSTALLDIRS=vendor
make
}
+check() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make test
+}
+
package() {
cd "${srcdir}/${_realname}-${pkgver}"
make install DESTDIR="${pkgdir}"
@@ -37,4 +40,3 @@ package() {
find "${pkgdir}" -name perllocal.pod -delete
find "${pkgdir}" -name .packlist -delete
}
-