summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-class-std-fast/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-class-std-fast/PKGBUILD b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
new file mode 100644
index 0000000..71878e6
--- /dev/null
+++ b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname='perl-class-std-fast'
+pkgver='0.0.8'
+pkgrel='1'
+pkgdesc="Class::Std::Fast allows you to use the beautiful API of Class::Std in a faster way than Class::Std"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl' 'perl-class-std')
+makedepends=()
+url='http://search.cpan.org/~acid/Class-Std-Fast/'
+source=('http://search.cpan.org/CPAN/authors/id/A/AC/ACID/Class-Std-Fast-v0.0.8.tar.gz')
+_distdir="Class-Std-Fast-v0.0.8"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+md5sums=('d06d084cb84f295b0aabf2eee78ef746')