summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-font-ttf/PKGBUILD40
-rw-r--r--abs/core/perl_modules/perl-io-string/PKGBUILD28
-rw-r--r--abs/core/perl_modules/perl-sort-versions/PKGBUILD35
3 files changed, 103 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-font-ttf/PKGBUILD b/abs/core/perl_modules/perl-font-ttf/PKGBUILD
new file mode 100644
index 0000000..f745e1c
--- /dev/null
+++ b/abs/core/perl_modules/perl-font-ttf/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer:
+# Contributor: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Jason St. John <jstjohn .. purdue . edu>
+# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+# Contributor: Francois Charette <firmicus@gmx.net>
+
+_perlmod='Font-TTF'
+_modnamespace='Font'
+pkgname="perl-${_perlmod,,}"
+pkgver=1.06
+pkgrel=3
+pkgdesc="${_perlmod//-/::} - Perl module for TrueType font hacking"
+arch=(any)
+url="http://search.cpan.org/dist/${_perlmod}"
+license=('Artistic2.0')
+depends=(perl-io-string)
+options=(!emptydirs)
+_verwatch=("http://www.cpan.org/modules/by-module/${_modnamespace}/" "${_perlmod}-\([0-9\.]*\)\.tar\.gz" 'l')
+source=("${_verwatch[0]}${_perlmod}-${pkgver}.tar.gz")
+sha256sums=('4b697d444259759ea02d2c442c9bffe5ffe14c9214084a01f743693a944cc293')
+
+build() {
+ cd "${_perlmod}-${pkgver}"
+
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl 'Makefile.PL' INSTALLDIRS='vendor'
+ make
+}
+
+check() {
+ cd "${_perlmod}-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${_perlmod}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+ rm -r "$pkgdir"/usr/lib
+}
+
diff --git a/abs/core/perl_modules/perl-io-string/PKGBUILD b/abs/core/perl_modules/perl-io-string/PKGBUILD
new file mode 100644
index 0000000..df44d3c
--- /dev/null
+++ b/abs/core/perl_modules/perl-io-string/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: François Charette <firmicus ατ gmx δοτ net>
+
+pkgname=perl-io-string
+pkgver=1.08
+pkgrel=11
+pkgdesc="IO::File interface for in-core strings"
+arch=('x86_64')
+url="http://search.cpan.org/dist/IO-String"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(https://www.cpan.org/authors/id/G/GA/GAAS/IO-String-$pkgver.tar.gz)
+sha256sums=('2a3f4ad8442d9070780e58ef43722d19d1ee21a803bf7c8206877a10482de5a0')
+
+build() {
+ cd "$srcdir"/IO-String-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/IO-String-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
+}
diff --git a/abs/core/perl_modules/perl-sort-versions/PKGBUILD b/abs/core/perl_modules/perl-sort-versions/PKGBUILD
new file mode 100644
index 0000000..fd6f215
--- /dev/null
+++ b/abs/core/perl_modules/perl-sort-versions/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+# Contributor: dracorp aka Piotr Rogoza <piotr dot r dot public at gmail.com>
+
+_author=N/NE/NEILB
+_perlmod=Sort-Versions
+pkgname=perl-sort-versions
+pkgver=1.62
+pkgrel=4
+pkgdesc='Sort::Versions - a perl 5 module for sorting of revision-like numbers'
+arch=('any')
+url="http://search.cpan.org/dist/Sort-Versions/"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha512sums=('b30dab96a5a31023af3ecee1857ae7bf5abc45b266294b47abb4f03c332b27825c1139d1a56bf0cfbd538487d28b3be167d83f9f5a93f079717b40157abe4d96')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1
+build(){
+ cd "$srcdir/$_perlmod-$pkgver"
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd $_perlmod-$pkgver
+ make test
+}
+
+package() {
+ cd $_perlmod-$pkgver
+ make install DESTDIR="$pkgdir/"
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}