summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-appconfig/PKGBUILD33
-rw-r--r--abs/core/perl_modules/perl-class-std-fast/PKGBUILD40
-rw-r--r--abs/core/perl_modules/perl-class-std/PKGBUILD49
-rw-r--r--abs/core/perl_modules/perl-data-dump/PKGBUILD31
-rw-r--r--abs/core/perl_modules/perl-data-uuid/PKGBUILD51
-rw-r--r--abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD23
-rw-r--r--abs/core/perl_modules/perl-soap-lite/PKGBUILD8
-rw-r--r--abs/core/perl_modules/perl-sys-cpu/PKGBUILD30
-rw-r--r--abs/core/perl_modules/perl-sys-meminfo/PKGBUILD50
-rw-r--r--abs/core/perl_modules/perl-template-toolkit/PKGBUILD40
-rw-r--r--abs/core/perl_modules/perl-wsdl/PKGBUILD26
11 files changed, 377 insertions, 4 deletions
diff --git a/abs/core/perl_modules/perl-appconfig/PKGBUILD b/abs/core/perl_modules/perl-appconfig/PKGBUILD
new file mode 100644
index 0000000..41f9422
--- /dev/null
+++ b/abs/core/perl_modules/perl-appconfig/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: eric <eric@archlinux.org>
+# Contributor: Eric Johnson <eric@coding-zone.com>
+
+pkgname=perl-appconfig
+_realname=AppConfig
+pkgver=1.71
+pkgrel=1
+pkgdesc="Perl/CPAN AppConfig module - Read configuration files and parse command line arguments"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perl')
+options=('!emptydirs')
+source=("http://www.cpan.org/authors/id/N/NE/NEILB/${_realname}-${pkgver}.tar.gz")
+md5sums=('7747d9241561ed5567d5e134b8648707')
+
+build() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+}
diff --git a/abs/core/perl_modules/perl-class-std-fast/PKGBUILD b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
new file mode 100644
index 0000000..71878e6
--- /dev/null
+++ b/abs/core/perl_modules/perl-class-std-fast/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname='perl-class-std-fast'
+pkgver='0.0.8'
+pkgrel='1'
+pkgdesc="Class::Std::Fast allows you to use the beautiful API of Class::Std in a faster way than Class::Std"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl' 'perl-class-std')
+makedepends=()
+url='http://search.cpan.org/~acid/Class-Std-Fast/'
+source=('http://search.cpan.org/CPAN/authors/id/A/AC/ACID/Class-Std-Fast-v0.0.8.tar.gz')
+_distdir="Class-Std-Fast-v0.0.8"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+md5sums=('d06d084cb84f295b0aabf2eee78ef746')
diff --git a/abs/core/perl_modules/perl-class-std/PKGBUILD b/abs/core/perl_modules/perl-class-std/PKGBUILD
new file mode 100644
index 0000000..dafacbc
--- /dev/null
+++ b/abs/core/perl_modules/perl-class-std/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-class-std'
+pkgver='0.013'
+pkgrel='1'
+pkgdesc="Support for creating standard \"inside-out\" classes"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Class-Std'
+source=('http://search.cpan.org/CPAN/authors/id/C/CH/CHORNY/Class-Std-0.013.tar.gz')
+_distdir="Class-Std-$pkgver"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et:
+md5sums=('82bcc56d9769edce671b0bd0e183ec3a')
diff --git a/abs/core/perl_modules/perl-data-dump/PKGBUILD b/abs/core/perl_modules/perl-data-dump/PKGBUILD
new file mode 100644
index 0000000..a40b423
--- /dev/null
+++ b/abs/core/perl_modules/perl-data-dump/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer:
+
+pkgname=perl-data-dump
+pkgver=1.23
+pkgrel=1
+pkgdesc="Pretty printing of data structures"
+arch=(any)
+url="https://metacpan.org/release/Data-Dump"
+license=(PerlArtistic GPL)
+depends=('perl')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Data-Dump-${pkgver}.tar.gz")
+sha1sums=('7da875cde34b6fe32b680eaa0c70121e4b69f09b')
+sha1sums=('3f5c0d4a15c8dd6befbcdceb41fe15b9aef1b741')
+
+build() {
+ cd Data-Dump-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd Data-Dump-${pkgver}
+ make test
+}
+
+package() {
+ cd Data-Dump-${pkgver}
+ make DESTDIR="$pkgdir" install
+}
diff --git a/abs/core/perl_modules/perl-data-uuid/PKGBUILD b/abs/core/perl_modules/perl-data-uuid/PKGBUILD
new file mode 100644
index 0000000..a20fbe4
--- /dev/null
+++ b/abs/core/perl_modules/perl-data-uuid/PKGBUILD
@@ -0,0 +1,51 @@
+# CPAN Name : Data-UUID
+# Contributor: Anonymous
+# Generator : CPANPLUS::Dist::Arch 1.30
+
+pkgname='perl-data-uuid'
+pkgver='1.221'
+pkgrel='1'
+pkgdesc="Globally/Universally Unique Identifiers (GUIDs/UUIDs)"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=0')
+makedepends=()
+url='https://metacpan.org/release/Data-UUID'
+source=('http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Data-UUID-1.221.tar.gz')
+md5sums=('7619929e8fe205a7fb83bc1c29ecbf99')
+sha512sums=('fa40219890f9adeb486a7ff636603d8695d81765ee858e396130100aaba96b524d80eef76e0c06eac2086fe3bb2d26114d94459466d29ddc82a7a7fcb2f5adac')
+_distdir="Data-UUID-1.221"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD b/abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD
new file mode 100644
index 0000000..5bf7764
--- /dev/null
+++ b/abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=perl-io-socket-multicast
+pkgver=1.12
+pkgrel=2
+pkgdesc="IO::Socket::Multicast - Object interface to socket communications for perl"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url="http://search.cpan.org/dist/IO-Socket-Multicast/"
+source=("http://search.cpan.org/CPAN/authors/id/B/BR/BRAMBLE/IO-Socket-Multicast-$pkgver.tar.gz")
+md5sums=('c96e6cbb367b1d11ffe7bb9fbd833540')
+
+build() {
+ cd "$srcdir/IO-Socket-Multicast-$pkgver"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/IO-Socket-Multicast-$pkgver"
+ make DESTDIR=$pkgdir install
+}
diff --git a/abs/core/perl_modules/perl-soap-lite/PKGBUILD b/abs/core/perl_modules/perl-soap-lite/PKGBUILD
index d885fcb..f5e8ee2 100644
--- a/abs/core/perl_modules/perl-soap-lite/PKGBUILD
+++ b/abs/core/perl_modules/perl-soap-lite/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 163581 2012-07-16 06:21:11Z giovanni $
+# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-soap-lite
-pkgver=0.715
+pkgver=1.20
pkgrel=1
pkgdesc="Client and server side SOAP implementation"
arch=('any')
@@ -42,8 +42,8 @@ provides=(
perl-xmlrpc-transport-pop3
perl-xmlrpc-transport-tcp
)
-source=("http://www.cpan.org/authors/id/M/MK/MKUTTER/SOAP-Lite-${pkgver}.tar.gz")
-md5sums=('a44c41291ddddaa19c02a72cd554327b')
+source=("http://search.cpan.org/CPAN/authors/id/P/PH/PHRED/SOAP-Lite-${pkgver}.tar.gz")
+md5sums=('b49632017cb5ba43c85d60cbe638af07')
build() {
cd "${srcdir}/SOAP-Lite-${pkgver}"
diff --git a/abs/core/perl_modules/perl-sys-cpu/PKGBUILD b/abs/core/perl_modules/perl-sys-cpu/PKGBUILD
new file mode 100644
index 0000000..325fd89
--- /dev/null
+++ b/abs/core/perl_modules/perl-sys-cpu/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Chris Kitching <chriskitching@linux.com>
+# Essentially stolen from Nathan Hulse <nat.hulse@gmail.com>
+# Oddly it disappeared from the AUR, and I want creduce, so I dug it
+# up and mopped the blood off.
+
+pkgname=perl-sys-cpu
+pkgver=0.61
+pkgrel=1
+pkgdesc="Perl extension for getting CPU information. Currently only number of CPU's supported."
+arch=('any')
+url="http://search.cpan.org/~mkoderer/Sys-CPU-$pkgver/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=(https://cpan.metacpan.org/authors/id/M/MZ/MZSANFORD/Sys-CPU-$pkgver.tar.gz)
+md5sums=(f43a3a50ac2dca6c1485a859ebef09b2)
+
+build() {
+ cd "$srcdir/Sys-CPU-$pkgver"
+
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/Sys-CPU-$pkgver"
+ make install DESTDIR="$pkgdir/"
+}
+
diff --git a/abs/core/perl_modules/perl-sys-meminfo/PKGBUILD b/abs/core/perl_modules/perl-sys-meminfo/PKGBUILD
new file mode 100644
index 0000000..05ef17d
--- /dev/null
+++ b/abs/core/perl_modules/perl-sys-meminfo/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Francesco Di Battista <teme.[nospace]84 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-sys-meminfo'
+pkgver='0.98'
+pkgrel='1'
+pkgdesc="Perl extension for return the total amount of physical memory"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Sys-MemInfo'
+source=('http://search.cpan.org/CPAN/authors/id/S/SC/SCRESTO/Sys-MemInfo-0.98.tar.gz')
+md5sums=('a5636cf6ae8f1b32253b3ca6fa63653b')
+sha512sums=('06f3d5d5678832c688dae6b50392cfe549a105359be5d868d020bbb34839216ded7138cac1788d398330deaf260789e91a7a2c3f4998af1ddedf33006c31e1d4')
+_distdir="Sys-MemInfo-0.98"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/perl_modules/perl-template-toolkit/PKGBUILD b/abs/core/perl_modules/perl-template-toolkit/PKGBUILD
new file mode 100644
index 0000000..157cad2
--- /dev/null
+++ b/abs/core/perl_modules/perl-template-toolkit/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Firmicus <francois.archlinux.org>
+# Contributor: Tom Killian <tomk@runbox.com>
+# Contributor: FJ <joostef@gmail.com>
+
+pkgname=perl-template-toolkit
+pkgver=2.26
+pkgrel=3
+pkgdesc="Perl template processing system"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/dist/Template-Toolkit/"
+license=('PerlArtistic')
+depends=('perl-appconfig' 'perl')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/A/AB/ABW/Template-Toolkit-$pkgver.tar.gz)
+md5sums=('4c289856ebee446ebbe2629b24f0734b')
+
+build() {
+ cd Template-Toolkit-$pkgver
+ perl Makefile.PL INSTALLDIRS=vendor TT_ACCEPT=y
+ make
+}
+
+check() {
+ cd Template-Toolkit-$pkgver
+ make test
+}
+
+package() {
+ cd Template-Toolkit-$pkgver
+ make install DESTDIR="${pkgdir}"
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
+}
diff --git a/abs/core/perl_modules/perl-wsdl/PKGBUILD b/abs/core/perl_modules/perl-wsdl/PKGBUILD
new file mode 100644
index 0000000..e2c580f
--- /dev/null
+++ b/abs/core/perl_modules/perl-wsdl/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=perl-wsdl
+pkgver=3.003
+pkgrel=1
+pkgdesc="SOAP-WSDL provides a SOAP client with WSDL support"
+arch=(any)
+url="http://search.cpan.org/~swalters/SOAP-WSDL/"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'perl-class-load' 'perl-class-std-fast' 'perl-template-toolkit'
+ 'perl-term-readkey' 'perl-timedate' 'perl-uri' 'perl-libwww' 'perl-xml-parser')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/S/SW/SWALTERS/SOAP-WSDL-3.003.tar.gz)
+_distdir="SOAP-WSDL-$pkgver"
+
+build() {
+ cd "$srcdir/$_distdir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install DESTDIR=$pkgdir
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}
+md5sums=('454b0d4f71d211c77eb27f1eb7f33a1e')