summaryrefslogtreecommitdiffstats
path: root/abs/core/php/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/php/PKGBUILD')
-rw-r--r--abs/core/php/PKGBUILD54
1 files changed, 28 insertions, 26 deletions
diff --git a/abs/core/php/PKGBUILD b/abs/core/php/PKGBUILD
index 68ece33..975716a 100644
--- a/abs/core/php/PKGBUILD
+++ b/abs/core/php/PKGBUILD
@@ -1,9 +1,6 @@
-# $Id: PKGBUILD 4664 2008-07-08 13:58:05Z allan $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-
pkgname=php
pkgver=5.2.6
-pkgrel=4
+pkgrel=23
_suhosinver=0.9.6.2
pkgdesc='A high-level scripting language'
arch=('i686' 'x86_64')
@@ -12,10 +9,15 @@ url='http://www.php.net'
backup=('etc/php/php.ini')
install=php.install
depends=('glibc' 'readline' 'ncurses' 'libxml2' 'pcre')
-makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' \
- 'libpng' 'libjpeg' 'sqlite3' 'unixodbc' 'net-snmp' \
- 'libmcrypt' 'tidyhtml' 'aspell' 'libtool' 'freetype2' 'libjpeg' \
+#makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' \
+# 'libpng' 'libjpeg' 'sqlite3' 'unixodbc' 'net-snmp' \
+# 'libmcrypt' 'tidyhtml' 'aspell' 'libtool' 'freetype2' 'libjpeg' \
+# 'curl' 'libxslt' 'pam' 'openssl' 'bzip2' 'gdbm' 'db>=4.7')
+
+makedepends=('mysql' 'libpng' 'libjpeg' 'sqlite3' \
+ 'libmcrypt' 'libtool' 'freetype2' 'libjpeg' \
'curl' 'libxslt' 'pam' 'openssl' 'bzip2' 'gdbm' 'db>=4.7')
+
optdepends=('bzip2: bz2' \
'curl: curl' \
'gdbm: dba' \
@@ -37,12 +39,12 @@ optdepends=('bzip2: bz2' \
'libxslt: xsl' \
)
options=('emptydirs')
-source=("http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2" \
+source=("http://museum.php.net/php5/${pkgname}-${pkgver}.tar.bz2" \
"http://download.suhosin.org/suhosin-patch-${pkgver}-${_suhosinver}.patch.gz" \
'php.ini' 'apache.conf' 'db-configure.patch')
md5sums=('7380ffecebd95c6edb317ef861229ebd'
'f2ec986341a314c271259dbe4d940858'
- '0ee1dad48f7d67af3d2c78ca6eed68ba'
+ 'fda535c2b333297972aad48ee9285b45'
'96ca078be6729b665be8a865535a97bf'
'74e5ce5a02488ec91b1c59f539e42936')
@@ -78,9 +80,9 @@ build() {
--with-jpeg-dir=shared,/usr \
--with-png-dir=shared,/usr \
--with-gettext=shared \
- --with-imap=shared \
- --with-imap-ssl=shared \
- --with-ldap=shared \
+ --without-imap \
+ --without-imap-ssl \
+ --without-ldap \
--enable-mbstring=shared \
--with-mcrypt=shared \
--with-mysql=shared \
@@ -88,22 +90,22 @@ build() {
--with-mysql=shared \
--with-mysqli=shared \
--with-ncurses=shared \
- --with-unixODBC=shared,/usr \
+ --without-unixODBC \
--enable-pdo=shared \
--with-pdo-mysql=shared \
--with-pdo-sqlite=shared \
- --with-pdo-odbc=shared,unixODBC,/usr \
- --with-pdo-pgsql=shared \
+ --without-pdo-odbc \
+ --without-pdo-pgsql \
--with-sqlite=shared \
- --with-pgsql=shared \
+ --without-pgsql \
--enable-shmop=shared \
- --with-snmp=shared \
+ --without-snmp \
--enable-soap=shared \
--enable-sqlite-utf8=shared \
--enable-sysvmsg=shared \
--enable-sysvsem=shared \
--enable-sysvshm=shared \
- --with-tidy=shared \
+ --without-tidy \
--with-xsl=shared \
--enable-zip=shared \
--enable-posix=shared \
@@ -118,7 +120,7 @@ build() {
--enable-json=shared \
--with-iconv=shared \
--with-xmlrpc=shared \
- --with-pspell=shared \
+ --without-pspell \
--with-freetype-dir=shared,/usr \
--with-mime-magic=shared \
"
@@ -164,11 +166,11 @@ build() {
install -D -m755 sapi/cgi/php-cgi ${pkgdir}/usr/bin/php-cgi || return 1
# mod_php
- ./configure ${phpconfig} \
- --with-apxs2 \
- --disable-cli \
- ${phpextensions} || return 1
- make || return 1
- install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
- install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
+# ./configure ${phpconfig} \
+# --with-apxs2 \
+# --disable-cli \
+# ${phpextensions} || return 1
+# make || return 1
+# install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
+# install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
}