summaryrefslogtreecommitdiffstats
path: root/abs/core/pinentry/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/pinentry/PKGBUILD')
-rw-r--r--abs/core/pinentry/PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/abs/core/pinentry/PKGBUILD b/abs/core/pinentry/PKGBUILD
index 072a2b2..2da4a57 100644
--- a/abs/core/pinentry/PKGBUILD
+++ b/abs/core/pinentry/PKGBUILD
@@ -1,26 +1,24 @@
-# $Id: PKGBUILD 160802 2012-06-06 10:36:53Z tpowa $
+# $Id$
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=pinentry
-pkgver=0.8.1
-pkgrel=4
+pkgver=0.9.0
+pkgrel=1
pkgdesc="a collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
arch=('i686' 'x86_64')
license=('GPL')
-url="http://www.gnupg.org/aegypten2"
+url="http://gnupg.org/related_software/pinentry/"
depends=('ncurses' 'libcap>=2.16')
-makedepends=('gtk2' 'qt')
+makedepends=('gtk2' 'qt4')
optdepends=('gtk2: for gtk2 backend'
- 'qt: for qt4 backend')
-source=(ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.gz
- qt4-pinentry-window.patch)
+ 'qt4: for qt4 backend')
+source=(ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2)
install=pinentry.install
+md5sums=('40a05856cb3accf6679987b7899b0f5a')
build() {
cd $srcdir/$pkgname-$pkgver
- #fix: https://bugs.archlinux.org/task/29998
- patch -Np1 -i ../qt4-pinentry-window.patch
for file in qt4/*.moc; do
- /usr/bin/moc ${file/.moc/.h} > ${file}
+ moc-qt4 ${file/.moc/.h} > ${file}
done
./configure --prefix=/usr \
--enable-pinentry-curses \
@@ -36,5 +34,3 @@ package() {
cd $srcdir/$pkgname-$pkgver
make DESTDIR=${pkgdir} install
}
-md5sums=('81f99904daee5331eb6738408bb024b6'
- '450b8713fe42f1bd93311ef84767c3d8')