summaryrefslogtreecommitdiffstats
path: root/abs/core/ppl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/ppl/PKGBUILD')
-rw-r--r--abs/core/ppl/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/ppl/PKGBUILD b/abs/core/ppl/PKGBUILD
new file mode 100644
index 0000000..ee5979a
--- /dev/null
+++ b/abs/core/ppl/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 87232 2010-08-11 12:07:18Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: ezzetabi <ezzetabi at gawab dot com>
+
+pkgname=ppl
+pkgver=0.11
+pkgrel=1
+pkgdesc="A modern library for convex polyhedra and other numerical abstractions."
+arch=('i686' 'x86_64')
+url="http://www.cs.unipr.it/ppl"
+license=('GPL3')
+depends=('gmp>=5.0')
+options=('!docs' '!libtool')
+source=(http://www.cs.unipr.it/ppl/Download/ftp/releases/$pkgver/ppl-$pkgver.tar.gz)
+md5sums=('ba527ec0ffc830ce16fad8a4195a337e')
+
+build() {
+ cd $srcdir/ppl-$pkgver
+ ./configure --prefix=/usr --enable-interfaces="c,cxx"
+ make
+ make check
+}
+
+package() {
+ cd $srcdir/ppl-$pkgver
+ make DESTDIR=$pkgdir install
+}