summaryrefslogtreecommitdiffstats
path: root/abs/core/procps-ng
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/procps-ng')
-rw-r--r--abs/core/procps-ng/PKGBUILD40
-rw-r--r--abs/core/procps-ng/sysctl.conf41
2 files changed, 81 insertions, 0 deletions
diff --git a/abs/core/procps-ng/PKGBUILD b/abs/core/procps-ng/PKGBUILD
new file mode 100644
index 0000000..deede7e
--- /dev/null
+++ b/abs/core/procps-ng/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 170098 2012-11-01 17:28:55Z bisson $
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=procps-ng
+pkgver=3.3.5
+pkgrel=1
+pkgdesc='Utilities for monitoring your system and its processes'
+url="http://gitorious.org/procps"
+license=('GPL' 'LGPL')
+arch=('i686' 'x86_64')
+groups=('base')
+depends=('ncurses')
+conflicts=('procps')
+provides=('procps')
+replaces=('procps')
+backup=('etc/sysctl.conf')
+options=('!libtool')
+source=("procps-ng-${pkgver}.tar.gz::http://gitorious.org/procps/procps/archive-tarball/v${pkgver}"
+ 'sysctl.conf')
+sha1sums=('f591f2ff01f8866daf8999f45b797d18929b7aec'
+ '97ff07bab9aa5daa8d54a1346f73ba74f8e12a53')
+
+build() {
+ cd "${srcdir}/procps-procps"
+ echo ${pkgver} > .tarball-version
+ ./autogen.sh
+ ./configure --exec-prefix=/ --prefix=/usr --sysconfdir=/etc --libdir=/usr/lib
+ make
+}
+
+package() {
+ cd "${srcdir}/procps-procps"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 ../sysctl.conf "${pkgdir}/etc/sysctl.conf"
+
+ # provided by util-linux
+ rm "${pkgdir}/bin/kill"
+ rm "${pkgdir}/usr/share/man/man1/kill.1"
+}
diff --git a/abs/core/procps-ng/sysctl.conf b/abs/core/procps-ng/sysctl.conf
new file mode 100644
index 0000000..4695cdd
--- /dev/null
+++ b/abs/core/procps-ng/sysctl.conf
@@ -0,0 +1,41 @@
+# Configuration file for runtime kernel parameters.
+# See sysctl.conf(5) for more information.
+
+# Have the CD-ROM close when you use it, and open when you are done.
+#dev.cdrom.autoclose = 1
+#dev.cdrom.autoeject = 1
+
+# Protection from the SYN flood attack.
+net.ipv4.tcp_syncookies = 1
+
+# See evil packets in your logs.
+#net.ipv4.conf.all.log_martians = 1
+
+# Never accept redirects or source routes (these are only useful for routers).
+#net.ipv4.conf.all.accept_redirects = 0
+#net.ipv4.conf.all.accept_source_route = 0
+#net.ipv6.conf.all.accept_redirects = 0
+#net.ipv6.conf.all.accept_source_route = 0
+
+# Disable packet forwarding.
+net.ipv4.ip_forward = 0
+net.ipv6.conf.all.forwarding = 0
+
+# Tweak the port range used for outgoing connections.
+#net.ipv4.ip_local_port_range = 32768 61000
+
+# Tweak those values to alter disk syncing and swap behavior.
+#vm.vfs_cache_pressure = 100
+#vm.laptop_mode = 0
+#vm.swappiness = 60
+
+# Tweak how the flow of kernel messages is throttled.
+#kernel.printk_ratelimit_burst = 10
+#kernel.printk_ratelimit = 5
+
+# Reboot 600 seconds after kernel panic or oops.
+#kernel.panic_on_oops = 1
+#kernel.panic = 600
+
+# Disable SysRq key to avoid console security issues.
+kernel.sysrq = 0