summaryrefslogtreecommitdiffstats
path: root/abs/core/python/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python/PKGBUILD')
-rw-r--r--abs/core/python/PKGBUILD57
1 files changed, 29 insertions, 28 deletions
diff --git a/abs/core/python/PKGBUILD b/abs/core/python/PKGBUILD
index bc812de..16ebac5 100644
--- a/abs/core/python/PKGBUILD
+++ b/abs/core/python/PKGBUILD
@@ -1,57 +1,58 @@
-# $Id: PKGBUILD 4689 2008-07-08 21:50:56Z andyrtr $
+# $Id: PKGBUILD 20912 2008-12-07 08:52:24Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributer: Jason Chu <jason@archlinux.org>
pkgname=python
-pkgver=2.5.2
-pkgrel=5
-_pybasever=2.5
+pkgver=2.6.1
+pkgrel=1
+_pybasever=2.6
pkgdesc="A high-level scripting language"
arch=('i686' 'x86_64')
license=('custom')
url="http://www.python.org"
-depends=('db4.5' 'bzip2' 'gdbm' 'openssl>=0.9.8d' 'zlib')
+depends=('db' 'bzip2' 'gdbm' 'openssl>=0.9.8d' 'zlib')
makedepends=('tk>=8.5.0' 'sqlite3')
-provides=('python-elementree' 'python-ctypes')
-replaces=('python-elementree' 'python-ctypes')
-install=python.install
+optdepends=('tk: for IDLE, pynche and modulator')
+provides=('python-elementtree' 'python-ctypes')
+replaces=('python-elementtree' 'python-ctypes')
source=(http://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.bz2
+ python-2.6-internal-expat.patch
+ python-2.6-gdbm.patch
modulator-launcher
- pynche-launcher
- Python-2.4.4-gdbm-1.patch
- python-2.5.CVE-2007-4965-int-overflow.patch
- python2.6-set_wakeup_fd4.patch
- Python-2.5.2-idlelib.patch)
-md5sums=('afb5451049eda91fbde10bd5a4b7fadc'
- 'faa0d4b947bfe67fc8684b5c464f46f2'
- '60a44af1d8af276274e20c564c0f3d8b'
- '2b61e06365e9fb5f3af22d946efa8be6'
- '491416c1b337fc61b6cdf5981d895a7d'
- 'ec56710959deb01b5fa35829cafec6a3'
- 'e6441e0b013ac64795221154e0495e10')
+ pynche-launcher)
+md5sums=('e81c2f0953aa60f8062c05a4673f2be0'
+ '993800dbcc0c4f199c1ceee998a06e71'
+ '13fab4bb2cacbc433e62d7191a17f71e'
+ 'b4a531570415280dc406c8d5c1fa8d83'
+ '9f731b9033db285132a3524fb36409e7')
+
build() {
- cd ${startdir}/src/Python-${pkgver}
- patch -Np1 -i ${srcdir}/Python-2.4.4-gdbm-1.patch || return 1
- # fix http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4965
- patch -Np1 -i ${srcdir}/python-2.5.CVE-2007-4965-int-overflow.patch || return 1
-
- patch -Np2 -i ${srcdir}/python2.6-set_wakeup_fd4.patch || return 1
- patch -Np0 -i ${srcdir}/Python-2.5.2-idlelib.patch
+ cd ${srcdir}/Python-${pkgver}
+
+ patch -Np0 -i ${srcdir}/python-2.6-internal-expat.patch
+ patch -Np1 -i ${srcdir}/python-2.6-gdbm.patch
./configure --prefix=/usr --enable-shared --with-threads --enable-unicode
+
+ # temporary backwards compatibility stuff...
+ sed -i 's#SITEPATH=#SITEPATH=:/usr/lib/python2.5/site-packages#' Makefile
+
make || return 1
make DESTDIR=${pkgdir} install
rm ${pkgdir}/usr/bin/python
ln -sf python${_pybasever} ${pkgdir}/usr/bin/python
+ ln -sf python${_pybasever} ${pkgdir}/usr/bin/python2
# Install the tools
#modulator
+ sed -i "s#%%PYBASEVER%%#${_pybasever}#" ${srcdir}/modulator-launcher
install -m755 ${srcdir}/modulator-launcher ${pkgdir}/usr/bin/modulator
cp -r Tools/modulator ${pkgdir}/usr/lib/python${_pybasever}/site-packages/
#pynche
+ sed -i "s#%%PYBASEVER%%#${_pybasever}#" ${srcdir}/pynche-launcher
install -m755 ${srcdir}/pynche-launcher ${pkgdir}/usr/bin/pynche
rm -f Tools/pynche/*.pyw
cp -r Tools/pynche ${pkgdir}/usr/lib/python${_pybasever}/site-packages/
@@ -65,5 +66,5 @@ build() {
install Tools/scripts/*py ${pkgdir}/usr/lib/python${_pybasever}/Tools/scripts/
# license
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}