summaryrefslogtreecommitdiffstats
path: root/abs/core/python/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python/PKGBUILD')
-rw-r--r--abs/core/python/PKGBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/abs/core/python/PKGBUILD b/abs/core/python/PKGBUILD
index 16ebac5..6de8863 100644
--- a/abs/core/python/PKGBUILD
+++ b/abs/core/python/PKGBUILD
@@ -1,42 +1,41 @@
-# $Id: PKGBUILD 20912 2008-12-07 08:52:24Z allan $
+# $Id: PKGBUILD 75257 2010-04-01 05:30:58Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributer: Jason Chu <jason@archlinux.org>
pkgname=python
-pkgver=2.6.1
-pkgrel=1
+pkgver=2.6.5
+pkgrel=3
_pybasever=2.6
pkgdesc="A high-level scripting language"
arch=('i686' 'x86_64')
-license=('custom')
+license=('PSF')
url="http://www.python.org"
-depends=('db' 'bzip2' 'gdbm' 'openssl>=0.9.8d' 'zlib')
-makedepends=('tk>=8.5.0' 'sqlite3')
+depends=('db>=4.8' 'bzip2' 'gdbm' 'openssl' 'zlib' 'expat' 'sqlite3')
+makedepends=('tk>=8.5.0')
optdepends=('tk: for IDLE, pynche and modulator')
-provides=('python-elementtree' 'python-ctypes')
+provides=('python2' 'python-elementtree' 'python-ctypes')
replaces=('python-elementtree' 'python-ctypes')
source=(http://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.bz2
python-2.6-internal-expat.patch
- python-2.6-gdbm.patch
+ python-2.6-db-4.8.patch
modulator-launcher
pynche-launcher)
-md5sums=('e81c2f0953aa60f8062c05a4673f2be0'
+md5sums=('6bef0417e71a1a1737ccf5750420fdb3'
'993800dbcc0c4f199c1ceee998a06e71'
- '13fab4bb2cacbc433e62d7191a17f71e'
+ '10eb5449ead95b9cb13eae9f9a65894e'
'b4a531570415280dc406c8d5c1fa8d83'
'9f731b9033db285132a3524fb36409e7')
-
build() {
cd ${srcdir}/Python-${pkgver}
patch -Np0 -i ${srcdir}/python-2.6-internal-expat.patch
- patch -Np1 -i ${srcdir}/python-2.6-gdbm.patch
+ #http://bugs.python.org/issue6949
+ patch -Np0 -i ${srcdir}/python-2.6-db-4.8.patch
+
+ export OPT="${CFLAGS}"
./configure --prefix=/usr --enable-shared --with-threads --enable-unicode
-
- # temporary backwards compatibility stuff...
- sed -i 's#SITEPATH=#SITEPATH=:/usr/lib/python2.5/site-packages#' Makefile
make || return 1
make DESTDIR=${pkgdir} install
@@ -45,6 +44,9 @@ build() {
ln -sf python${_pybasever} ${pkgdir}/usr/bin/python
ln -sf python${_pybasever} ${pkgdir}/usr/bin/python2
+ ln -sf ../../libpython${_pybasever}.so \
+ ${pkgdir}/usr/lib/python${_pybasever}/config/libpython${_pybasever}.so
+
# Install the tools
#modulator
sed -i "s#%%PYBASEVER%%#${_pybasever}#" ${srcdir}/modulator-launcher
@@ -62,8 +64,8 @@ build() {
install -m755 Tools/i18n/msgfmt.py ${pkgdir}/usr/bin/
mkdir -p ${pkgdir}/usr/lib/python${_pybasever}/Tools/scripts
- install Tools/scripts/README ${pkgdir}/usr/lib/python${_pybasever}/Tools/scripts/
- install Tools/scripts/*py ${pkgdir}/usr/lib/python${_pybasever}/Tools/scripts/
+ install -m644 Tools/scripts/README ${pkgdir}/usr/lib/python${_pybasever}/Tools/scripts/
+ install -m755 Tools/scripts/*py ${pkgdir}/usr/lib/python${_pybasever}/Tools/scripts/
# license
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE