summaryrefslogtreecommitdiffstats
path: root/abs/core/python/python-2.6-gdbm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python/python-2.6-gdbm.patch')
-rw-r--r--abs/core/python/python-2.6-gdbm.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/abs/core/python/python-2.6-gdbm.patch b/abs/core/python/python-2.6-gdbm.patch
new file mode 100644
index 0000000..0f223f6
--- /dev/null
+++ b/abs/core/python/python-2.6-gdbm.patch
@@ -0,0 +1,12 @@
+diff -Naur Python-2.6-old/setup.py Python-2.6/setup.py
+--- Python-2.6-old/setup.py 2008-09-30 10:15:45.000000000 +1000
++++ Python-2.6/setup.py 2008-12-07 16:04:01.000000000 +1000
+@@ -1013,7 +1013,7 @@
+ if self.compiler.find_library_file(lib_dirs, 'ndbm'):
+ ndbm_libs = ['ndbm']
+ else:
+- ndbm_libs = []
++ ndbm_libs = ['gdbm', 'gdbm_compat']
+ exts.append( Extension('dbm', ['dbmmodule.c'],
+ define_macros=[('HAVE_NDBM_H',None)],
+ libraries = ndbm_libs ) )