summaryrefslogtreecommitdiffstats
path: root/abs/core/python2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python2/PKGBUILD')
-rw-r--r--abs/core/python2/PKGBUILD50
1 files changed, 29 insertions, 21 deletions
diff --git a/abs/core/python2/PKGBUILD b/abs/core/python2/PKGBUILD
index 8615d48..aabe74a 100644
--- a/abs/core/python2/PKGBUILD
+++ b/abs/core/python2/PKGBUILD
@@ -5,22 +5,27 @@
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python2
-pkgver=2.7.11
+pkgver=2.7.14
pkgrel=2
_pybasever=2.7
pkgdesc="A high-level scripting language"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('PSF')
url="http://www.python.org/"
depends=('bzip2' 'gdbm' 'openssl' 'zlib' 'expat' 'sqlite' 'libffi')
-makedepends=('tk' 'bluez-libs' 'hardening-wrapper')
-checkdepends=('gdb' 'file')
+makedepends=('tk' 'bluez-libs')
+checkdepends=('gdb' 'file' 'xorg-server-xvfb')
optdepends=('tk: for IDLE'
'python2-setuptools'
'python2-pip')
conflicts=('python<3')
-source=(http://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz)
-sha1sums=('c3b8bbe3f084c4d4ea13ffb03d75a5e22f9756ff')
+source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"{,.asc}
+ descr_ref.patch fix-profile-task.patch)
+sha512sums=('78310b0be6388ffa15f29a80afb9ab3c03a572cb094e9da00cfe391afadb51696e41f592eb658d6a31a2f422fdac8a55214a382cbb8cfb43d4a127d5b35ea7f9'
+ 'SKIP'
+ '2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d'
+ '5d7b47bfa9f13cf5fb827546189d823033278f96866366fca5257aaf819c92ffb26e2116426c84ab78d9ae3178eebb591fa4b2f22cfc2725e3e3e795fdb5c2b6')
+validpgpkeys=('C01E1CAD5EA2C4F0B8E3571504C367C218ADD4FF') # Benjamin Peterson
prepare() {
cd Python-${pkgver}
@@ -38,11 +43,6 @@ prepare() {
sed -i "s/python2.3/python2/g" Lib/distutils/tests/test_build_scripts.py \
Lib/distutils/tests/test_install_scripts.py
- # TODO: Still not passed
- # Silent test_gdb failures on 'no symbol table loaded'.
- #sed -i '/ignore_patterns = (/a "No symbol table is loaded. Use the \\"file\\" command.",' \
- # Lib/test/test_gdb.py
-
# Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
# rather than copies shipped in the tarball
rm -r Modules/expat
@@ -55,6 +55,13 @@ prepare() {
# Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
+
+ # FS#48761
+ # http://bugs.python.org/issue25750
+ patch -Np1 -i ../descr_ref.patch
+
+ # Backport from Python 3.x
+ patch -Np2 -i ../fix-profile-task.patch
}
build() {
@@ -64,6 +71,8 @@ build() {
./configure --prefix=/usr \
--enable-shared \
--with-threads \
+ --enable-optimizations \
+ --with-lto \
--enable-ipv6 \
--enable-unicode=ucs4 \
--with-system-expat \
@@ -75,23 +84,22 @@ build() {
}
check() {
- # As of 2.7.11, 2 tests failed:
- # test_doctest test_gdb
- # Besides, test_thread disabled as it will stuck
-
- # $SHELL was set to avoid a test failure in test_gdb (it still fails due to other reasons, though)
+ # Since 2.7.13,
+ # test_replace_overflow (present in test_bytes, test_str, test_string, test_unicode, test_userstring) segfault on i686
+ # test_bigrepeat (present in test_tuple) segfault on i686
cd Python-${pkgver}
- SHELL=/bin/sh LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
- "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_thread || warning "Tests failed"
+ LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
+ xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_bytes test_str test_string test_tuple test_unicode test_userstring
}
package() {
cd Python-${pkgver}
- make DESTDIR="${pkgdir}" altinstall maninstall
- #LinHES
- ln -sf python2 "${pkgdir}/usr/bin/python"
+ # Hack to avoid building again
+ sed -i 's/^all:.*$/all: build_all/' Makefile
+
+ make DESTDIR="${pkgdir}" altinstall maninstall
rm "${pkgdir}"/usr/share/man/man1/python.1