summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/cython/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/cython/PKGBUILD')
-rw-r--r--abs/core/python_modules/cython/PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/abs/core/python_modules/cython/PKGBUILD b/abs/core/python_modules/cython/PKGBUILD
new file mode 100644
index 0000000..6826749
--- /dev/null
+++ b/abs/core/python_modules/cython/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id$
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Igor Scabini <furester @ gmail.com>
+
+pkgname=(cython cython2)
+pkgbase=cython
+pkgver=0.27.3
+pkgrel=3
+pkgdesc="C-Extensions for Python"
+arch=(x86_64)
+url="http://cython.org"
+license=(APACHE)
+makedepends=(python-setuptools python2-setuptools)
+source=($pkgbase-$pkgver.tar.gz::"https://github.com/cython/cython/archive/$pkgver.tar.gz")
+sha256sums=('648feb8a257574a3e4ef854475e7d767732ef26e870d2f9fcc1ca5b244b3ac89')
+
+prepare() {
+ cp -r cython-$pkgver cython2-$pkgver
+ find cython2-$pkgver -name '*.py' | xargs sed -e 's|/usr/bin/env python|/usr/bin/env python2|' -e 's|/usr/bin/python|/usr/bin/python2|' -i
+}
+
+build() {
+ cd cython-$pkgver
+ python setup.py build
+
+ cd ../cython2-$pkgver
+ python2 setup.py build
+}
+
+package_cython() {
+ depends=(python python-setuptools)
+
+ cd cython-$pkgver
+ python setup.py install --root="$pkgdir" --skip-build
+
+ for f in cygdb cython cythonize; do
+ mv "$pkgdir"/usr/bin/$f "$pkgdir"/usr/bin/${f}3
+ ln -s ${f}3 "$pkgdir"/usr/bin/$f
+ done
+}
+
+package_cython2() {
+ depends=(python2 python2-setuptools)
+
+ cd cython2-$pkgver
+ python2 setup.py install --root="$pkgdir" --skip-build
+
+ for f in cygdb cython cythonize; do
+ mv "$pkgdir"/usr/bin/$f "$pkgdir"/usr/bin/${f}2
+ done
+}