summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/gnome-python-extras
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/gnome-python-extras')
-rw-r--r--abs/core/python_modules/gnome-python-extras/PKGBUILD26
-rw-r--r--abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-pkg-config.patch61
-rw-r--r--abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-xulrunner.patch22
3 files changed, 0 insertions, 109 deletions
diff --git a/abs/core/python_modules/gnome-python-extras/PKGBUILD b/abs/core/python_modules/gnome-python-extras/PKGBUILD
deleted file mode 100644
index 690ec2e..0000000
--- a/abs/core/python_modules/gnome-python-extras/PKGBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-# $Id: PKGBUILD 35285 2009-04-11 20:46:50Z jgc $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-
-pkgname=gnome-python-extras
-pkgver=2.25.3
-pkgrel=2
-pkgdesc="Gnome Python interfaces for libraries not part of the core platform"
-arch=('i686' 'x86_64')
-license=('GPL' 'LGPL')
-depends=('gnome-python>=2.22.1')
-makedepends=('libgtkhtml' 'gtkspell' 'gdl' 'xulrunner>=1.9' 'libgksu' 'pkgconfig' 'libgnomeui' 'libgda')
-optdepends=('libgtkhtml' 'gtkspell' 'gdl' 'xulrunner' 'libgksu' 'libgnomeui' 'libgda')
-options=('!libtool')
-source=(http://ftp.gnome.org/pub/gnome/sources/gnome-python-extras/2.25/gnome-python-extras-${pkgver}.tar.bz2)
-url="http://www.daa.com.au/~james/pygtk/"
-md5sums=('9f3b7ec5c57130b96061cb486b79c076')
-
-build() {
- cd "${srcdir}/gnome-python-extras-${pkgver}"
- ./configure --prefix=/usr || return 1
- make MOZILLA_HOME=/usr/lib/xulrunner-1.9 || return 1
-}
-package() {
- cd "${srcdir}/gnome-python-extras-${pkgver}"
- make DESTDIR="${pkgdir}" install || return 1
-}
diff --git a/abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-pkg-config.patch b/abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-pkg-config.patch
deleted file mode 100644
index 77fd0a4..0000000
--- a/abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-pkg-config.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -up gnome-python-extras-2.19.1/configure.pkg-config gnome-python-extras-2.19.1/configure
---- gnome-python-extras-2.19.1/configure.pkg-config 2008-01-12 21:07:56.000000000 -0500
-+++ gnome-python-extras-2.19.1/configure 2008-01-12 21:09:49.000000000 -0500
-@@ -22096,14 +22096,14 @@ if test -n "$PKG_CONFIG"; then
- pkg_cv_GTKMOZEMBED_CFLAGS="$GTKMOZEMBED_CFLAGS"
- else
- if test -n "$PKG_CONFIG" && \
-- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$mozpackage-gtkmozembed >= \$mozpackage_required_version,
-+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\mozilla-gtkmozembed >= \$mozpackage_required_version,
- gtk+-2.0 >= 2.4.0\"") >&5
-- ($PKG_CONFIG --exists --print-errors "$mozpackage-gtkmozembed >= $mozpackage_required_version,
-+ ($PKG_CONFIG --exists --print-errors "mozilla-gtkmozembed >= $mozpackage_required_version,
- gtk+-2.0 >= 2.4.0") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; then
-- pkg_cv_GTKMOZEMBED_CFLAGS=`$PKG_CONFIG --cflags "$mozpackage-gtkmozembed >= $mozpackage_required_version,
-+ pkg_cv_GTKMOZEMBED_CFLAGS=`$PKG_CONFIG --cflags "mozilla-gtkmozembed >= $mozpackage_required_version,
- gtk+-2.0 >= 2.4.0" 2>/dev/null`
- else
- pkg_failed=yes
-@@ -22117,14 +22117,14 @@ if test -n "$PKG_CONFIG"; then
- pkg_cv_GTKMOZEMBED_LIBS="$GTKMOZEMBED_LIBS"
- else
- if test -n "$PKG_CONFIG" && \
-- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$mozpackage-gtkmozembed >= \$mozpackage_required_version,
-+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\mozilla-gtkmozembed >= \$mozpackage_required_version,
- gtk+-2.0 >= 2.4.0\"") >&5
-- ($PKG_CONFIG --exists --print-errors "$mozpackage-gtkmozembed >= $mozpackage_required_version,
-+ ($PKG_CONFIG --exists --print-errors "mozilla-gtkmozembed >= $mozpackage_required_version,
- gtk+-2.0 >= 2.4.0") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; then
-- pkg_cv_GTKMOZEMBED_LIBS=`$PKG_CONFIG --libs "$mozpackage-gtkmozembed >= $mozpackage_required_version,
-+ pkg_cv_GTKMOZEMBED_LIBS=`$PKG_CONFIG --libs "mozilla-gtkmozembed >= $mozpackage_required_version,
- gtk+-2.0 >= 2.4.0" 2>/dev/null`
- else
- pkg_failed=yes
-@@ -22144,10 +22144,10 @@ else
- _pkg_short_errors_supported=no
- fi
- if test $_pkg_short_errors_supported = yes; then
-- GTKMOZEMBED_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$mozpackage-gtkmozembed >= $mozpackage_required_version,
-+ GTKMOZEMBED_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "mozilla-gtkmozembed >= $mozpackage_required_version,
- gtk+-2.0 >= 2.4.0"`
- else
-- GTKMOZEMBED_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$mozpackage-gtkmozembed >= $mozpackage_required_version,
-+ GTKMOZEMBED_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "mozilla-gtkmozembed >= $mozpackage_required_version,
- gtk+-2.0 >= 2.4.0"`
- fi
- # Put the nasty error message in config.log where it belongs
-@@ -22179,7 +22179,7 @@ fi
- if test -n "$export_dynamic"; then
- GTKMOZEMBED_LIBS=`echo $GTKMOZEMBED_LIBS | sed -e "s/$export_dynamic//"`
- fi
--MOZILLA_HOME="`$PKG_CONFIG --variable=libdir $mozpackage-gtkmozembed`"
-+MOZILLA_HOME="`$PKG_CONFIG --variable=libdir mozilla-gtkmozembed`"
-
-
-
diff --git a/abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-xulrunner.patch b/abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-xulrunner.patch
deleted file mode 100644
index d2fa26e..0000000
--- a/abs/core/python_modules/gnome-python-extras/gnome-python-extras-2.19.1-xulrunner.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -up gnome-python-extras-2.19.1/docs/gtkmozembed/html/class-gtkmozembed.html.old gnome-python-extras-2.19.1/docs/gtkmozembed/html/class-gtkmozembed.html
-diff -up gnome-python-extras-2.19.1/docs/gtkmozembed/html/pygtkmozembed.devhelp.old gnome-python-extras-2.19.1/docs/gtkmozembed/html/pygtkmozembed.devhelp
-diff -up gnome-python-extras-2.19.1/docs/gtkmozembed/gtkmozembed-gtkmozembed.xml.old gnome-python-extras-2.19.1/docs/gtkmozembed/gtkmozembed-gtkmozembed.xml
-diff -up gnome-python-extras-2.19.1/gtkmozembed/gtkmozembed.override.old gnome-python-extras-2.19.1/gtkmozembed/gtkmozembed.override
-diff -up gnome-python-extras-2.19.1/gtkmozembed/gtkmozembed.defs.old gnome-python-extras-2.19.1/gtkmozembed/gtkmozembed.defs
---- gnome-python-extras-2.19.1/gtkmozembed/gtkmozembed.defs.old 2007-06-05 16:52:30.000000000 +0200
-+++ gnome-python-extras-2.19.1/gtkmozembed/gtkmozembed.defs 2007-11-27 12:54:42.000000000 +0100
-@@ -123,6 +123,14 @@
- )
- )
-
-+(define-function set_path
-+ (c-name "gtk_moz_embed_set_path")
-+ (return-type "none")
-+ (parameters
-+ '("char*" "aPath")
-+ )
-+)
-+
- (define-function gtk_moz_embed_set_profile_path
- (c-name "gtk_moz_embed_set_profile_path_deprecated")
- (return-type "none")