summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-cryptography/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-cryptography/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-cryptography/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-cryptography/PKGBUILD b/abs/core/python_modules/python-cryptography/PKGBUILD
new file mode 100644
index 0000000..f916ada
--- /dev/null
+++ b/abs/core/python_modules/python-cryptography/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgbase=python-cryptography
+pkgname=('python2-cryptography')
+pkgver=0.3
+pkgrel=1
+pkgdesc="A package designed to expose cryptographic recipes and primitives to Python developers"
+arch=('i686' 'x86_64')
+license=('Apache')
+url="http://pypi.python.org/pypi/cryptography"
+makedepends=('python2-setuptools' 'python2-six' 'python2-cffi')
+checkdepends=('python2-pytest' 'python2-cryptography-vectors'
+ 'python2-iso8601' 'python2-pretend')
+source=("http://pypi.python.org/packages/source/c/cryptography/cryptography-${pkgver}.tar.gz")
+md5sums=('1a9f2520acfef9489ac42fdc9a7be441')
+
+check() {
+ # Check python3 module
+# cd "${srcdir}"/cryptography-${pkgver}
+# python3 setup.py test
+
+ # Check python2 module
+ cd "${srcdir}"/cryptography-${pkgver}-python2
+ python2 setup.py test
+}
+
+prepare() {
+ cp -a cryptography-${pkgver}{,-python2}
+}
+
+build() {
+ # Build python 3 module
+ cd cryptography-${pkgver}
+# python3 setup.py build
+
+ # Build python 2 module
+ cd ../cryptography-${pkgver}-python2
+ python2 setup.py build
+}
+
+#package_python-cryptography() {
+# depends=('python' 'python-six' 'python-cffi')
+
+# cd cryptography-${pkgver}
+# python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+#}
+
+package_python2-cryptography() {
+ depends=('python2' 'python2-six' 'python2-cffi')
+
+ cd cryptography-${pkgver}-python2
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}