summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-nose/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-nose/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-nose/PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/abs/core/python_modules/python-nose/PKGBUILD b/abs/core/python_modules/python-nose/PKGBUILD
index be20823..beafe17 100644
--- a/abs/core/python_modules/python-nose/PKGBUILD
+++ b/abs/core/python_modules/python-nose/PKGBUILD
@@ -5,16 +5,16 @@
# Contributor: Cilyan Olowen <gaknar@gmail.com>
pkgbase=python-nose
-pkgname=('python2-nose' 'python-nose-doc')
-pkgver=1.3.1
-pkgrel=2
+pkgname=('python-nose' 'python2-nose' 'python-nose-doc')
+pkgver=1.3.7
+pkgrel=3
pkgdesc="A discovery-based unittest extension"
arch=('any')
url='http://readthedocs.org/docs/nose/'
license=('LGPL2.1')
-makedepends=('python2' 'python2-setuptools' 'python2-sphinx')
-source=("http://pypi.python.org/packages/source/n/nose/nose-${pkgver}.tar.gz")
-md5sums=('672398801ddf5ba745c55c6eed79c5aa')
+makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools' 'python2-sphinx')
+source=("https://pypi.python.org/packages/source/n/nose/nose-${pkgver}.tar.gz")
+md5sums=('4d3ad0ff07b61373d2cefc89c5d0b20b')
build() {
cd "$srcdir/nose-$pkgver"
@@ -22,12 +22,12 @@ build() {
cp -R "$srcdir/nose-$pkgver" "$srcdir/nose2-$pkgver"
}
-#package_python-nose() {
-# depends=('python' 'python-setuptools')
-# cd "$srcdir/nose-$pkgver"
-# python3 setup.py install --prefix=/usr --root="${pkgdir}"
-# mv "$pkgdir/usr/bin/nosetests" "$pkgdir/usr/bin/nosetests3"
-#}
+package_python-nose() {
+ depends=('python' 'python-setuptools')
+ cd "$srcdir/nose-$pkgver"
+ python3 setup.py install --prefix=/usr --root="${pkgdir}"
+ ln -s nosetests "$pkgdir/usr/bin/nosetests3"
+}
package_python2-nose() {
depends=('python2' 'python2-setuptools')
@@ -40,7 +40,7 @@ package_python2-nose() {
package_python-nose-doc(){
pkgdesc="Nose documentation and examples"
cd "$srcdir/nose-$pkgver/doc"
- make SPHINXBUILD=sphinx-build22 html
+ make SPHINXBUILD=sphinx-build2 html
mkdir -p "$pkgdir/usr/share/doc/python-nose"
cp -r .build/html "$pkgdir/usr/share/doc/python-nose"
cp -r ../examples "$pkgdir/usr/share/doc/python-nose"