summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-numpy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-numpy/PKGBUILD')
-rwxr-xr-x[-rw-r--r--]abs/core/python_modules/python-numpy/PKGBUILD55
1 files changed, 40 insertions, 15 deletions
diff --git a/abs/core/python_modules/python-numpy/PKGBUILD b/abs/core/python_modules/python-numpy/PKGBUILD
index 57b41f5..8c9c6be 100644..100755
--- a/abs/core/python_modules/python-numpy/PKGBUILD
+++ b/abs/core/python_modules/python-numpy/PKGBUILD
@@ -1,36 +1,61 @@
-# $Id: PKGBUILD 95257 2010-10-17 20:17:04Z ibiru $
+# $Id: PKGBUILD 138131 2011-09-17 03:10:10Z allan $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
-pkgname=python-numpy
-pkgver=1.5.0
-pkgrel=3
+pkgbase=python-numpy
+pkgname=('python2-numpy')
+pkgver=1.6.1
+pkgrel=1
pkgdesc="Scientific tools for Python"
arch=('i686' 'x86_64')
license=('custom')
url="http://numpy.scipy.org/"
-depends=('lapack' 'python2')
-makedepends=('python-nose' 'gcc-fortran')
-optdepends=('python-nose: test suite')
+makedepends=('lapack' 'python2' 'python2-distribute' 'gcc-fortran' 'python2-nose')
source=(http://downloads.sourceforge.net/numpy/numpy-${pkgver}.tar.gz)
-md5sums=('3a8bfdc434df782d647161c48943ee09')
+md5sums=('2bce18c08fc4fce461656f0f4dd9103e')
build() {
- cd "${srcdir}/numpy-${pkgver}"
+ cd "${srcdir}"
+ cp -a numpy-${pkgver} numpy-py2-${pkgver}
export Atlas=None
export LDFLAGS="$LDFLAGS -shared"
+
+ echo "Building Python2"
+ cd "${srcdir}/numpy-py2-${pkgver}"
python2 setup.py config_fc --fcompiler=gnu95 build
+
+ #echo "Building Python3"
+ #cd "${srcdir}/numpy-${pkgver}"
+ #python setup.py config_fc --fcompiler=gnu95 build
}
-package() {
- cd "${srcdir}/numpy-${pkgver}"
- python2 setup.py config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}"
+package_python2-numpy() {
+ depends=('lapack' 'python2')
+ optdepends=('python-nose: testsuite')
+
+ cd "${srcdir}/numpy-py2-${pkgver}"
+ python2 setup.py config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}" --optimize=1
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m755 -d "${pkgdir}/usr/share/licenses/python2-numpy"
+ install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-numpy/"
sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- $(find $pkgdir -name '*.py')
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
+ $(find ${pkgdir} -name '*.py')
+}
+
+package_python-numpy() {
+ depends=('lapack' 'python')
+ provides=("python3-numpy=${pkgver}")
+ replaces=('python3-numpy')
+ conflicts=('python3-numpy')
+
+ cd "${srcdir}/numpy-${pkgver}"
+ python setup.py config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}" --optimize=1
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/python3-numpy"
+ install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python3-numpy/"
}