summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pexpect/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-pexpect/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-pexpect/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-pexpect/PKGBUILD b/abs/core/python_modules/python-pexpect/PKGBUILD
new file mode 100644
index 0000000..938e3cb
--- /dev/null
+++ b/abs/core/python_modules/python-pexpect/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Aaron Schaefer <aaron@elasticdog.com>
+pkgname=python-pexpect
+pkgver=2.3
+pkgrel=3
+pkgdesc='A pure Python Expect-like module'
+arch=('i686' 'x86_64')
+url='http://pexpect.sourceforge.net/'
+license=('MIT')
+depends=('python2')
+source=("http://downloads.sourceforge.net/sourceforge/pexpect/pexpect-$pkgver.tar.gz")
+md5sums=('bf107cf54e67bc6dec5bea1f3e6a65c3')
+
+build() {
+ cd $startdir/src/pexpect-$pkgver
+ python2 setup.py install --root=$startdir/pkg || return 1
+ install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
+}