summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pybluez/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-pybluez/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-pybluez/PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/abs/core/python_modules/python-pybluez/PKGBUILD b/abs/core/python_modules/python-pybluez/PKGBUILD
index e48f941..99594e6 100644
--- a/abs/core/python_modules/python-pybluez/PKGBUILD
+++ b/abs/core/python_modules/python-pybluez/PKGBUILD
@@ -3,29 +3,29 @@
# Contributor: cs-cam - me.at.camdaniel.com
pkgbase=python-pybluez
-pkgname=(python2-pybluez)
-pkgver=0.20
+pkgname=(python-pybluez python2-pybluez)
+pkgver=0.22
pkgrel=2
pkgdesc="Python wrapper for the BlueZ Bluetooth stack"
-arch=('i686' 'x86_64')
-url="http://code.google.com/p/pybluez/"
+arch=('x86_64')
+url="http://karulis.github.io/pybluez/"
license=('GPL')
-makedepends=('python2' 'bluez-libs')
-source=(http://pybluez.googlecode.com/files/PyBluez-$pkgver.zip)
-md5sums=('1e7fad332d50f089bbce69070c877ef6')
+makedepends=('python-setuptools' 'python2-setuptools' 'bluez-libs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/karulis/pybluez/archive/$pkgver.tar.gz")
+md5sums=('06f71ca6d4216ace671d5e588ec85887')
-#package_python-pybluez() {
-# depends=('python' 'bluez-libs')
+package_python-pybluez() {
+ depends=('python' 'bluez-libs')
-# cd $srcdir/PyBluez-$pkgver
-# python setup.py install --root=$pkgdir
-# ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python3.3/site-packages/_bluetooth.so
-#}
+ cd "$srcdir"/pybluez-$pkgver
+ python setup.py install --root="$pkgdir"
+# ln -s bluetooth/_bluetooth.so "$pkgdir"/usr/lib/python3.3/site-packages/_bluetooth.so
+}
package_python2-pybluez() {
depends=('python2' 'bluez-libs')
- cd $srcdir/PyBluez-$pkgver
- python2 setup.py install --root=$pkgdir
-# ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python2.7/site-packages/_bluetooth.so
+ cd "$srcdir"/pybluez-$pkgver
+ python2 setup.py install --root="$pkgdir"
+# ln -s bluetooth/_bluetooth.so "$pkgdir"/usr/lib/python2.7/site-packages/_bluetooth.so
}