summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pytz/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-pytz/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-pytz/PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/abs/core/python_modules/python-pytz/PKGBUILD b/abs/core/python_modules/python-pytz/PKGBUILD
index 3e77d2a..fca20e0 100644
--- a/abs/core/python_modules/python-pytz/PKGBUILD
+++ b/abs/core/python_modules/python-pytz/PKGBUILD
@@ -3,16 +3,15 @@
# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
# Contributor: William Rea <sillywilly@gmail.com>
-pkgname=('python2-pytz')
-pkgver=2017.2
+pkgname=('python-pytz' 'python2-pytz')
+pkgver=2018.3
pkgrel=1
arch=('any')
url="http://pypi.python.org/pypi/pytz"
license=("MIT")
-makedepends=('python2')
-source=(https://pypi.python.org/packages/a4/09/c47e57fc9c7062b4e83b075d418800d322caa87ec0ac21e6308bd3a2d519/pytz-2017.2.zip{,.asc})
-md5sums=('f89bde8a811c8a1a5bac17eaaa94383c'
- 'SKIP')
+makedepends=('python' 'python2')
+source=("https://pypi.io/packages/source/p/pytz/pytz-${pkgver}.tar.gz")
+md5sums=('abb07c09c79f78d7c04f222a550c99ef')
validpgpkeys=('C7ECC365AB6F255E1EB9BA1701FA998FBAC6374A')
build(){
@@ -23,8 +22,7 @@ build(){
check(){
cd $srcdir/pytz-$pkgver/pytz/tests
-# python3 test_tzinfo.py
-
+ python3 test_tzinfo.py
python2 test_tzinfo.py
}
@@ -50,7 +48,7 @@ package_python2-pytz(){
cd $srcdir/pytz2-$pkgver
# python 2 fix
- sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' pytz/tzfile.py
+# sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' pytz/tzfile.py
python2 setup.py install --root="$pkgdir/"