summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-webencodings/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python-webencodings/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-webencodings/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-webencodings/PKGBUILD b/abs/core/python_modules/python-webencodings/PKGBUILD
new file mode 100644
index 0000000..95f05b0
--- /dev/null
+++ b/abs/core/python_modules/python-webencodings/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
+# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
+
+pkgbase=python-webencodings
+pkgname=('python2-webencodings')
+pkgver=0.5.1
+pkgrel=1
+arch=('any')
+url="https://github.com/gsnedders/python-webencodings"
+license=('BSD')
+makedepends=('python2' 'python2-setuptools')
+checkdepends=('python2-nose')
+source=(https://github.com/gsnedders/python-webencodings/archive/v$pkgver.tar.gz)
+md5sums=('7eb67377743cd55eaa356496c439471e')
+
+package_python-webencodings() {
+pkgdesc="This is a Python implementation of the WHATWG Encoding standard."
+depends=('python')
+ cd ${srcdir}/${pkgbase}-${pkgver}
+
+ python3 setup.py install --root=${pkgdir}
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-webencodings() {
+pkgdesc="This is a Python implementation of the WHATWG Encoding standard."
+depends=('python2')
+ cd ${srcdir}/${pkgbase}-${pkgver}
+
+ python2 setup.py install --root=${pkgdir}
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+check() {
+ cd ${srcdir}/${pkgbase}-${pkgver}/webencodings
+
+ nosetests tests.py
+
+ nosetests2 tests.py
+}