summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-flask-cors
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python2-flask-cors')
-rw-r--r--abs/core/python_modules/python2-flask-cors/PKGBUILD21
-rw-r--r--abs/core/python_modules/python2-flask-cors/README.md16
2 files changed, 37 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-flask-cors/PKGBUILD b/abs/core/python_modules/python2-flask-cors/PKGBUILD
new file mode 100644
index 0000000..08ea418
--- /dev/null
+++ b/abs/core/python_modules/python2-flask-cors/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Philipp Schmitt <philipp@schmitt.co>
+# GitHub: https://github.com/pschmitt/aur-python2-flask-cors
+pkgname=python2-flask-cors
+_pkgname=Flask-Cors
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="A Flask extension adding a decorator for CORS support"
+arch=('any')
+url='https://pypi.python.org/pypi/Flask-Cors'
+license=('')
+depends=('python2')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/F/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('50274b36f1c885669234590009583c43')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/python_modules/python2-flask-cors/README.md b/abs/core/python_modules/python2-flask-cors/README.md
new file mode 100644
index 0000000..fed19ae
--- /dev/null
+++ b/abs/core/python_modules/python2-flask-cors/README.md
@@ -0,0 +1,16 @@
+# python2-flask-
+
+## Description
+
+AUR package for python2-flask-cors
+
+## Installation
+
+```bash
+wget https://raw.github.com/pschmitt/aur-python2-flask-cors/master/PKGBUILD
+makepkg -si
+```
+
+## Links
+* Upstream: https://pypi.python.org/pypi/Flask-Cors
+* AUR: https://aur.archlinux.org/packages/python2-flask-cors