summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-ipaddress
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python2-ipaddress')
-rw-r--r--abs/core/python_modules/python2-ipaddress/LICENSE50
-rw-r--r--abs/core/python_modules/python2-ipaddress/PKGBUILD28
2 files changed, 78 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-ipaddress/LICENSE b/abs/core/python_modules/python2-ipaddress/LICENSE
new file mode 100644
index 0000000..41bd16b
--- /dev/null
+++ b/abs/core/python_modules/python2-ipaddress/LICENSE
@@ -0,0 +1,50 @@
+This package is a modified version of cpython's ipaddress module.
+It is therefore distributed under the PSF license, as follows:
+
+PYTHON SOFTWARE FOUNDATION LICENSE VERSION 2
+--------------------------------------------
+
+1. This LICENSE AGREEMENT is between the Python Software Foundation
+("PSF"), and the Individual or Organization ("Licensee") accessing and
+otherwise using this software ("Python") in source or binary form and
+its associated documentation.
+
+2. Subject to the terms and conditions of this License Agreement, PSF hereby
+grants Licensee a nonexclusive, royalty-free, world-wide license to reproduce,
+analyze, test, perform and/or display publicly, prepare derivative works,
+distribute, and otherwise use Python alone or in any derivative version,
+provided, however, that PSF's License Agreement and PSF's notice of copyright,
+i.e., "Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
+2011, 2012, 2013, 2014 Python Software Foundation; All Rights Reserved" are
+retained in Python alone or in any derivative version prepared by Licensee.
+
+3. In the event Licensee prepares a derivative work that is based on
+or incorporates Python or any part thereof, and wants to make
+the derivative work available to others as provided herein, then
+Licensee hereby agrees to include in any such work a brief summary of
+the changes made to Python.
+
+4. PSF is making Python available to Licensee on an "AS IS"
+basis. PSF MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR
+IMPLIED. BY WAY OF EXAMPLE, BUT NOT LIMITATION, PSF MAKES NO AND
+DISCLAIMS ANY REPRESENTATION OR WARRANTY OF MERCHANTABILITY OR FITNESS
+FOR ANY PARTICULAR PURPOSE OR THAT THE USE OF PYTHON WILL NOT
+INFRINGE ANY THIRD PARTY RIGHTS.
+
+5. PSF SHALL NOT BE LIABLE TO LICENSEE OR ANY OTHER USERS OF PYTHON
+FOR ANY INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES OR LOSS AS
+A RESULT OF MODIFYING, DISTRIBUTING, OR OTHERWISE USING PYTHON,
+OR ANY DERIVATIVE THEREOF, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.
+
+6. This License Agreement will automatically terminate upon a material
+breach of its terms and conditions.
+
+7. Nothing in this License Agreement shall be deemed to create any
+relationship of agency, partnership, or joint venture between PSF and
+Licensee. This License Agreement does not grant permission to use PSF
+trademarks or trade name in a trademark sense to endorse or promote
+products or services of Licensee, or any third party.
+
+8. By copying, installing or otherwise using Python, Licensee
+agrees to be bound by the terms and conditions of this License
+Agreement.
diff --git a/abs/core/python_modules/python2-ipaddress/PKGBUILD b/abs/core/python_modules/python2-ipaddress/PKGBUILD
new file mode 100644
index 0000000..d5a0bd5
--- /dev/null
+++ b/abs/core/python_modules/python2-ipaddress/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Nikolaus Brandt <sua-aur-661bbb3b@brandt-n.eu>
+
+pkgname=python2-ipaddress
+pkgver=1.0.16
+pkgrel=1
+pkgdesc="IPv4/IPv6 manipulation library"
+arch=(any)
+url="https://github.com/phihag/ipaddress"
+license=('custom:PSF')
+depends=('python2')
+source=("https://pypi.python.org/packages/source/i/ipaddress/ipaddress-$pkgver.tar.gz"
+ LICENSE)
+sha512sums=('50baf15f185b039037eef7b047d5a0ffbe1b335d2d94c218b6a2012ae1ba89c5e5c4f64667d8a623e4e4e7598d90c8a7caa8327ea4c155260ab90384f86a6c89'
+ '5cc59a125412b0eb35f05d40756db050805fc1bd5729f350796644ad92b8117f8d3ed3c7cf6ab8b072518706bf95a1d40f016d065726a1296e19ea09582ec385')
+
+check() {
+ # Not included in release tarball
+ cd ipaddress-$pkgver
+ # python2 test_ipaddress.py
+}
+
+package() {
+ cd ipaddress-$pkgver
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}