summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-oauth/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules/python2-oauth/PKGBUILD')
-rw-r--r--abs/core/python_modules/python2-oauth/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-oauth/PKGBUILD b/abs/core/python_modules/python2-oauth/PKGBUILD
new file mode 100644
index 0000000..83f3f09
--- /dev/null
+++ b/abs/core/python_modules/python2-oauth/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Jonathan Conder <jonno.conder@gmail.com>
+# Contributor: Snowknight (hopkinsth@gmail.com)
+
+_pkgbasename=oauth
+pkgname=python2-oauth
+pkgver=1.0.1
+pkgrel=3
+pkgdesc="An open protocol to allow API authentication from desktop and web applications."
+arch=('any')
+url="https://code.google.com/archive/p/oauth/"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+conflicts=('python-oauth')
+replaces=('python-oauth')
+source=("https://files.pythonhosted.org/packages/source/${_pkgbasename:0:1}/$_pkgbasename/$_pkgbasename-$pkgver.tar.gz")
+sha256sums=('e769819ff0b0c043d020246ce1defcaadd65b9c21d244468a45a7f06cb88af5d')
+
+build() {
+ cd $_pkgbasename-$pkgver
+
+ python2 setup.py build
+}
+
+package() {
+ cd $_pkgbasename-$pkgver
+
+ python2 setup.py install -O1 --root="$pkgdir"
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}