summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-path/PKGBUILD40
-rw-r--r--abs/core/python_modules/python-path/__changelog2
2 files changed, 42 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-path/PKGBUILD b/abs/core/python_modules/python-path/PKGBUILD
new file mode 100644
index 0000000..2b7dcbc
--- /dev/null
+++ b/abs/core/python_modules/python-path/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 171328 2016-04-18 11:00:47Z kkeen $
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+
+pkgbase=python-path
+pkgname=(python2-path)
+pkgver=10.1
+pkgrel=1
+pkgdesc="Aka path.py, implements path objects as first-class entities"
+arch=('any')
+url="https://pypi.python.org/pypi/path.py"
+license=('MIT')
+depends=('python2' 'python2-setuptools')
+makedepends=('python2-setuptools')
+#source=("https://pypi.python.org/packages/source/p/path.py/path.py-$pkgver.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/p/path.py/path.py-$pkgver.tar.gz")
+md5sums=('f9d31317ceeb798f6b5eac8d3b8e5988')
+
+# formerly a dependency of python-pickleshare
+# now used by nothing so back to the AUR
+
+prepare() {
+ cd "$srcdir"
+ cp -r path.py-$pkgver python2-path.py-$pkgver
+}
+
+package_python-path() {
+ depends=('python' 'python-setuptools')
+ cd "$srcdir/path.py-$pkgver"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=0
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ head -n 21 path.py > "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
+
+package_python2-path() {
+ depends=('python2' 'python2-setuptools')
+ cd "$srcdir/python2-path.py-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=0
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ head -n 21 path.py > "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
diff --git a/abs/core/python_modules/python-path/__changelog b/abs/core/python_modules/python-path/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-path/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+