summaryrefslogtreecommitdiffstats
path: root/abs/core/qt/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/qt/PKGBUILD')
-rw-r--r--abs/core/qt/PKGBUILD56
1 files changed, 33 insertions, 23 deletions
diff --git a/abs/core/qt/PKGBUILD b/abs/core/qt/PKGBUILD
index 75e4737..e1ee827 100644
--- a/abs/core/qt/PKGBUILD
+++ b/abs/core/qt/PKGBUILD
@@ -1,23 +1,31 @@
-# $Id: PKGBUILD 82062 2010-06-08 11:58:32Z pierre $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+# $Id: PKGBUILD 94734 2010-10-10 14:30:15Z andrea $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=qt
-pkgver=4.6.3
-pkgrel=2
+pkgver=4.7.0
+pkgrel=4
pkgdesc='A cross-platform application and UI framework'
arch=('i686' 'x86_64')
url='http://qt.nokia.com/'
license=('GPL3' 'LGPL')
-depends=('libpng' 'fontconfig' 'libtiff' 'libmng' 'sqlite3' 'xdg-utils' 'ca-certificates'
- 'hicolor-icon-theme' 'alsa-lib' 'glib2' 'dbus' 'libxrender' 'libgl' 'libsm')
-optdepends=('postgresql-libs' 'libmysqlclient' 'unixodbc')
-makedepends=('mesa' 'inputproto' 'postgresql-libs' 'mysql' 'unixodbc' 'libxfixes' 'gtk2')
-install=qt.install
+depends=('libtiff' 'libpng' 'libmng' 'sqlite3' 'ca-certificates' 'glib2' 'dbus'
+ 'fontconfig' 'libgl' 'libsm' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
+ 'xdg-utils' 'hicolor-icon-theme')
+optdepends=('postgresql-libs: PostgreSQL driver'
+ 'libmysqlclient: MySQL driver'
+ 'unixodbc: ODBC driver'
+ 'libxinerama: Xinerama support'
+ 'libxcursor: Xcursor support'
+ 'libxfixes: Xfixes support')
+makedepends=('mesa' 'postgresql-libs' 'mysql' 'unixodbc' 'gtk2')
+install="${pkgname}.install"
options=('!libtool')
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
source=("ftp://ftp.qt.nokia.com/qt/source/${_pkgfqn}.tar.gz"
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qtconfig.desktop'
- 'ca-certificates.patch' 'qt-webkit-4.6.3-flash-plugin-segfault.patch')
+ 'fix-scroll-when-last-item-is-removed.patch'
+ 'fix-multisampling-with-ati-card.patch')
build() {
unset QMAKESPEC
@@ -27,22 +35,22 @@ build() {
cd $srcdir/$_pkgfqn
- # see http://cvs.fedoraproject.org/viewvc/rpms/qt/devel/
- # use system ssl cert bundle
- patch -p1 -i $srcdir/ca-certificates.patch || return 1
- patch -p0 < $srcdir/qt-webkit-4.6.3-flash-plugin-segfault.patch || return 1
+ # Already fixed in 4.7.1
+ patch -Np1 -i ${srcdir}/fix-scroll-when-last-item-is-removed.patch
+ patch -Np1 -i ${srcdir}/fix-multisampling-with-ati-card.patch
sed -i "s|-O2|$CXXFLAGS|" mkspecs/common/g++.conf
sed -i "/^QMAKE_RPATH/s| -Wl,-rpath,||g" mkspecs/common/g++.conf
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= $LDFLAGS|g" mkspecs/common/g++.conf
- ./configure -confirm-license -opensource \
+ ./configure -v -confirm-license -opensource \
-prefix /usr \
- -sysconfdir /etc \
+ -docdir /usr/share/doc/qt \
-plugindir /usr/lib/qt/plugins \
- -translationdir /usr/share/qt/translations \
+ -importdir /usr/lib/qt/imports \
-datadir /usr/share/qt \
- -docdir /usr/share/doc/qt \
+ -translationdir /usr/share/qt/translations \
+ -sysconfdir /etc \
-examplesdir /usr/share/doc/qt/examples \
-demosdir /usr/share/doc/qt/demos \
-largefile \
@@ -53,22 +61,24 @@ build() {
-no-phonon-backend \
-svg \
-webkit \
+ -script \
-scripttools \
-system-zlib \
-system-libtiff \
-system-libpng \
-system-libmng \
-system-libjpeg \
- -openssl-linked \
-nomake demos \
-nomake examples \
-nomake docs \
-no-rpath \
+ -no-cups \
+ -openssl-linked \
-silent \
-optimized-qmake \
-dbus \
- -no-separate-debug-info \
-reduce-relocations \
+ -no-separate-debug-info \
-gtkstyle \
-opengl \
-no-openvg \
@@ -101,10 +111,10 @@ package() {
find ${pkgdir}/usr/lib -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
}
-md5sums=('5c69f16d452b0bb3d44bc3c10556c072'
+md5sums=('3a2f25b9b115037277f4fb759194a7a5'
'a445c6917086d80f1cfc1e40cb6b0132'
'd457f0a0ad68a3861c3cadefe3b42ded'
'668331d9798a0e2b94381efb7be4c513'
'c29f2993d6a0f73d756d2fa36e130e1c'
- 'd5c4cad7af93f1d736d4569a207bd739'
- '17382f5532888268bb50d1ab47e5fa19')
+ 'ef20c34afc5be5ed62f2935be66d9402'
+ 'b2e0f134bbb848ebef41134a45a36ee9')