summaryrefslogtreecommitdiffstats
path: root/abs/core/qt5-doc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/qt5-doc/PKGBUILD')
-rw-r--r--abs/core/qt5-doc/PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/abs/core/qt5-doc/PKGBUILD b/abs/core/qt5-doc/PKGBUILD
new file mode 100644
index 0000000..1984921
--- /dev/null
+++ b/abs/core/qt5-doc/PKGBUILD
@@ -0,0 +1,63 @@
+# $Id: PKGBUILD 240297 2015-06-03 10:22:03Z fyan $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Michael Hansen <zrax0111 gmail com>
+
+pkgname=qt5-doc
+_qtver=5.10.1
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('any')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='A cross-platform application and UI framework (Documentation)'
+depends=('qt5-base')
+makedepends=('qt5-tools' 'python2' 'pciutils' 'libxtst' 'libxcursor' 'libxrandr' 'libxss' 'libxcomposite' 'gperf' 'nss')
+groups=('qt' 'qt5')
+_pkgfqn="qt-everywhere-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfqn}.tar.xz"
+ qt-no-statx.patch)
+sha256sums=('05ffba7b811b854ed558abf2be2ddbd3bb6ddd0b60ea4b5da75d277ac15e740a'
+ '5cd1d90622cc53609806a3ce0b2811b28f0e6e20eb835861de4492dddeef6e52')
+
+prepare() {
+ cd ${_pkgfqn}
+
+ ln -s /usr/bin qttools/
+ ln -s /usr/bin/{rcc,uic,moc} qtbase/bin/
+
+ # Hack to force using python2
+ cd "$srcdir"
+ mkdir -p bin
+ ln -s /usr/bin/python2 bin/python
+
+ # Don't use the statx syscall https://bugs.archlinux.org/task/56289 https://bugreports.qt.io/browse/QTBUG-64490
+ cd ${_pkgfqn}/qtbase
+ patch -p1 -i "$srcdir"/qt-no-statx.patch
+}
+
+build() {
+ cd ${_pkgfqn}
+
+ export PATH="$srcdir/bin:$PATH"
+ PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource \
+ -prefix /usr \
+ -docdir /usr/share/doc/qt \
+ -headerdir /usr/include/qt \
+ -archdatadir /usr/lib/qt \
+ -datadir /usr/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /usr/share/doc/qt/examples
+ make docs
+}
+
+package() {
+ cd ${_pkgfqn}
+ make INSTALL_ROOT="$pkgdir" install_docs
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
+
+# Fix conflicts with qt5-examples
+ rm -r "$pkgdir"/usr/share/doc/qt/examples
+}