summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/runit-scripts/PKGBUILD')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
new file mode 100755
index 0000000..1615994
--- /dev/null
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=runit-scripts
+pkgver=1.8.0
+pkgrel=95
+pkgdesc="collection of startup scripts for runit"
+url="http://smarden.org/runit/"
+license="BSD"
+depends=('glibc' 'util-linux' 'initscripts' 'runit' )
+makedepends=('rsync')
+conflicts=()
+replaces=()
+backup=(etc/runit/1.local)
+install=runit.install
+source=(fbsplash-runit.sh)
+arch=('i686')
+
+build() {
+ rsync -a --exclude=.svn --exclude=*~ $startdir/runitscripts $startdir/src
+ cd $startdir/src/runitscripts
+ install -d $startdir/pkg/etc/
+ install -d $startdir/pkg/etc/runit/
+ install -d $startdir/pkg/var/service
+ install -d $startdir/pkg/etc/sv
+ install -d $startdir/pkg/sbin
+ install -d $startdir/pkg/etc/rc.d/functions.d
+
+ install -m0700 1 2 3 1.local ctrlaltdel $startdir/pkg/etc/runit
+ install -m755 $startdir/src/fbsplash-runit.sh $startdir/pkg/etc/rc.d/functions.d/fbsplash-runit.sh
+ install -m0755 reboot-runit halt-runit logger $startdir/pkg/sbin
+ rsync -a --exclude=.svn services/* $startdir/pkg/etc/sv
+}
+md5sums=('c6cbd6af3657783bd1ce8f75f574d72f')