summaryrefslogtreecommitdiffstats
path: root/abs/core/setserial/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/setserial/PKGBUILD')
-rw-r--r--abs/core/setserial/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/core/setserial/PKGBUILD b/abs/core/setserial/PKGBUILD
new file mode 100644
index 0000000..acab19d
--- /dev/null
+++ b/abs/core/setserial/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: aurelien <aurelien@archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+pkgname=setserial
+pkgver=2.17
+pkgrel=2
+pkgdesc="Allows to change various attributes of a serial device."
+url="http://setserial.sourceforge.net/"
+depends=('glibc')
+
+arch=(i686)
+source=(http://dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz $pkgname.patch)
+md5sums=('c4867d72c41564318e0107745eb7a0f2' '99919d3be7c1550721494070a7ace66a')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 -i ../$pkgname.patch
+ ./configure --prefix=/usr
+ make || return 1
+ mkdir -p $startdir/pkg/usr/{bin,man/man8}
+ make DESTDIR=$startdir/pkg install
+}