summaryrefslogtreecommitdiffstats
path: root/abs/core/sqlite3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/sqlite3/PKGBUILD')
-rw-r--r--abs/core/sqlite3/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core/sqlite3/PKGBUILD b/abs/core/sqlite3/PKGBUILD
new file mode 100644
index 0000000..acf7a94
--- /dev/null
+++ b/abs/core/sqlite3/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 22976 2008-12-30 11:35:01Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=sqlite3
+pkgver=3.6.10
+pkgrel=5
+pkgdesc="A C library that implements an SQL database engine"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.sqlite.org/"
+depends=('readline')
+makedepends=('tcl')
+conflicts=('sqlite')
+replaces=('sqlite')
+source=(http://www.sqlite.org/sqlite-$pkgver.tar.gz
+ license.txt)
+md5sums=('a03bdc86df4025b6881d58557e4b5bd3'
+ 'c1cdbc5544034d9012e421e75a5e4890')
+options=(!libtool)
+
+build() {
+ cd ${srcdir}/sqlite-${pkgver}
+ export LTLINK_EXTRAS="-ldl"
+ export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1"
+ ./configure --prefix=/usr \
+ --enable-threadsafe \
+ --disable-static \
+ --enable-load-extension || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -Dm0644 sqlite3.1 ${pkgdir}/usr/share/man/man1/sqlite3.1
+
+ # license
+ install -Dm644 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
+}