summaryrefslogtreecommitdiffstats
path: root/abs/core/talloc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/talloc/PKGBUILD')
-rw-r--r--abs/core/talloc/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/talloc/PKGBUILD b/abs/core/talloc/PKGBUILD
new file mode 100644
index 0000000..903de2d
--- /dev/null
+++ b/abs/core/talloc/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 63108 2010-01-14 18:54:03Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=talloc
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="talloc is a hierarchical pool based memory allocator with destructors"
+arch=(i686 x86_64)
+license=('GPL3')
+url="http://tdb.samba.org/"
+source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+depends=('glibc')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ --enable-talloc-compat1 \
+ --enable-largefile
+ make || return 1
+ make DESTDIR=$pkgdir/ install
+ # fix permission
+ chmod 644 $pkgdir/usr/lib/libtalloc.a
+}
+md5sums=('c6e736540145ca58cb3dcb42f91cf57b')