summaryrefslogtreecommitdiffstats
path: root/abs/core/tdb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/tdb/PKGBUILD')
-rw-r--r--abs/core/tdb/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/tdb/PKGBUILD b/abs/core/tdb/PKGBUILD
new file mode 100644
index 0000000..e908119
--- /dev/null
+++ b/abs/core/tdb/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 37511 2009-05-02 16:17:09Z tpowa $
+# Maintainer: eric <eric@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=tdb
+pkgver=3.3.4
+pkgrel=1
+# We use the 'A' to fake out pacman's version comparators. Samba chooses
+# to append 'a','b',etc to their subsequent releases, which pamcan
+# misconstrues as alpha, beta, etc. Bad samba!
+_realver=3.3.4
+pkgdesc="A Trivial Database similar to GDBM but allows simultaneous commits"
+arch=(i686 x86_64)
+license=('GPL3')
+url="www.samba.org"
+source=(http://us1.samba.org/samba/ftp/samba-${_realver}.tar.gz)
+options=(!makeflags)
+
+build() {
+ cd ${srcdir}/samba-${_realver}/source/lib/tdb
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ ln -sf /usr/lib/libtdb.so.1.1.2 ${pkgdir}/usr/lib/libtdb.so.1
+ ln -sf /usr/lib/libtdb.so.1.1.2 ${pkgdir}/usr/lib/libtdb.so
+}
+md5sums=('1443165edb7cb3f56f1e77aec1ee3266')