summaryrefslogtreecommitdiffstats
path: root/abs/core/tilda
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/tilda')
-rw-r--r--abs/core/tilda/PKGBUILD53
-rw-r--r--abs/core/tilda/__changelog2
-rw-r--r--abs/core/tilda/tilda-0.9.6.tar.gzbin307517 -> 0 bytes
-rw-r--r--abs/core/tilda/tilda-conf-sigsegv.patch11
-rw-r--r--abs/core/tilda/tilda-fix.patch24
-rw-r--r--abs/core/tilda/tilda-glib2.patch11
-rw-r--r--abs/core/tilda/tilda.changelog20
-rw-r--r--abs/core/tilda/tilda.install44
-rw-r--r--abs/core/tilda/tilda_hide.patch35
9 files changed, 141 insertions, 59 deletions
diff --git a/abs/core/tilda/PKGBUILD b/abs/core/tilda/PKGBUILD
index f8422bc..814a5c3 100644
--- a/abs/core/tilda/PKGBUILD
+++ b/abs/core/tilda/PKGBUILD
@@ -1,26 +1,49 @@
-# Maintainer: William Rea <sillywilly@gmail.com>
+# $Id: PKGBUILD 71879 2012-06-02 18:37:37Z jlichtblau $
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
pkgname=tilda
pkgver=0.9.6
-pkgrel=2
-pkgdesc="Linux terminal based on classic terminals from first person shooter games."
+pkgrel=7
+pkgdesc="Linux terminal based on classic terminals from first person shooter games"
+arch=('i686' 'x86_64')
url="http://tilda.sourceforge.net"
-license="GPL"
-depends=('vte' 'confuse' 'libglade' 'gtk2')
+license=('GPL')
+depends=('vte' 'confuse' 'libglade')
makedepends=('gawk')
-source=('tilda-0.9.6.tar.gz' 'config_0')
-arch=('i686')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+tilda-fix.patch tilda-glib2.patch tilda-conf-sigsegv.patch config_0 tilda_hide.patch )
+
build() {
+ cd $srcdir/$pkgname-$pkgver
+
+# gdk && desktop file fix FS#25762
+ patch -p0 -i ${srcdir}/$pkgname-fix.patch
+
+# glib2 fix
+ patch -p0 -i ${srcdir}/$pkgname-glib2.patch
- cd $startdir/src/tilda-$pkgver/src
-# patch -p0 < $startdir/src/tilda.patch
- cd $startdir/src/tilda-$pkgver
+# fix segfaults on malformed config files FS#29754
+ patch -p0 -i ${srcdir}/$pkgname-conf-sigsegv.patch
+
+ patch -p0 -i ${srcdir}/tilda_hide.patch
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make DESTDIR=${pkgdir} install
- mkdir -p $startdir/pkg/etc
- cp $startdir/src/config_0 $startdir/pkg/etc/tilda_config
+ #default config
+ install -D -m 0755 $startdir/src/config_0 $startdir/pkg/etc/tilda_config
}
md5sums=('b44ebe04fdfd312e9ddc5e0ed77f4289'
- '754753190e0990cd6fba27b3c931bd0e')
+ '6ca2c5ae5acd254b1e89b319b118b8e1'
+ 'f1fc7009418c2ed7b506d5c555f072cb'
+ '3e08a0b2d48bba69cf96bef1faeca429'
+ '754753190e0990cd6fba27b3c931bd0e'
+ '0cc3020eabc74d939b0b978944d11693')
diff --git a/abs/core/tilda/__changelog b/abs/core/tilda/__changelog
new file mode 100644
index 0000000..b637dfd
--- /dev/null
+++ b/abs/core/tilda/__changelog
@@ -0,0 +1,2 @@
+tilda_hide patch
+This stops tilda from showing the config wizard unless tilda is started with -C
diff --git a/abs/core/tilda/tilda-0.9.6.tar.gz b/abs/core/tilda/tilda-0.9.6.tar.gz
deleted file mode 100644
index cb5531c..0000000
--- a/abs/core/tilda/tilda-0.9.6.tar.gz
+++ /dev/null
Binary files differ
diff --git a/abs/core/tilda/tilda-conf-sigsegv.patch b/abs/core/tilda/tilda-conf-sigsegv.patch
new file mode 100644
index 0000000..a48aad0
--- /dev/null
+++ b/abs/core/tilda/tilda-conf-sigsegv.patch
@@ -0,0 +1,11 @@
+--- src/key_grabber.c 2008-04-08 00:12:31.000000000 +0200
++++ src/key_grabber.c 2012-05-17 19:43:25.227699421 +0200
+@@ -257,7 +257,7 @@
+ gboolean tilda_keygrabber_bind (const gchar *keystr, tilda_window *tw)
+ {
+ /* Empty strings are no good */
+- if (strcmp ("", keystr) == 0)
++ if (!keystr || strcmp ("", keystr) == 0)
+ return FALSE;
+
+ return tomboy_keybinder_bind (keystr, onKeybindingPull, tw);
diff --git a/abs/core/tilda/tilda-fix.patch b/abs/core/tilda/tilda-fix.patch
new file mode 100644
index 0000000..a6d273c
--- /dev/null
+++ b/abs/core/tilda/tilda-fix.patch
@@ -0,0 +1,24 @@
+--- src/key_grabber.c 2008-04-08 01:12:31.000000000 +0300
++++ src/key_grabber.c 2009-10-16 17:39:16.399679408 +0300
+@@ -190,7 +190,7 @@
+ * Overriding the user time here seems to work a lot better than calling
+ * gtk_window_present_with_time() here, or at the end of the function. I have
+ * no idea why, they should do the same thing. */
+- gdk_x11_window_set_user_time (GTK_WIDGET(tw->window)->window,
++ gdk_x11_window_set_user_time (GTK_WIDGET(tw->window),
+ tomboy_keybinder_get_current_event_time());
+ gtk_window_move (GTK_WINDOW(tw->window), config_getint ("x_pos"), config_getint ("y_pos"));
+ gtk_widget_show (GTK_WIDGET(tw->window));
+
+--- tilda.desktop.in 2007-03-16 04:53:34.000000000 +0100
++++ tilda.desktop.in 2011-08-28 19:08:53.000000000 +0200
+@@ -2 +1,0 @@
+-Encoding=UTF-8
+@@ -4,2 +3,2 @@
+-Exec=@BINDIR@/tilda
+-Icon=@PIXMAPSDIR@/tilda.png
++Exec=tilda
++Icon=tilda
+@@ -8 +7 @@
+-Categories=GNOME;GTK;Application;Utility;TerminalEmulator;
++Categories=GNOME;GTK;Utility;TerminalEmulator;System;
diff --git a/abs/core/tilda/tilda-glib2.patch b/abs/core/tilda/tilda-glib2.patch
new file mode 100644
index 0000000..2d048e5
--- /dev/null
+++ b/abs/core/tilda/tilda-glib2.patch
@@ -0,0 +1,11 @@
+--- src/tomboykeybinder.h 2007-07-15 04:31:19.000000000 +0200
++++ src/tomboykeybinder.h 2012-05-17 19:42:06.613150329 +0200
+@@ -2,7 +2,7 @@
+ #ifndef __TOMBOY_KEY_BINDER_H__
+ #define __TOMBOY_KEY_BINDER_H__
+
+-#include <glib/gtypes.h>
++//#include <glib/gtypes.h>
+
+ G_BEGIN_DECLS
+
diff --git a/abs/core/tilda/tilda.changelog b/abs/core/tilda/tilda.changelog
new file mode 100644
index 0000000..4248e9a
--- /dev/null
+++ b/abs/core/tilda/tilda.changelog
@@ -0,0 +1,20 @@
+2012-06-02 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+ * FS#29754 fixed
+
+2011-08-28 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+ * FS#25762 fixed
+
+2008-04-29 Mateusz Herych <heniekk@gmail.com>
+
+ * Updated for x86_64 - 0.9.6
+
+2008-04-28 Douglas Soares de Andrade <dsa@aur.archlinux.org>
+
+ * Updated for i686 - 0.9.6
+
+2007-12-30 Douglas Soares de Andrade <dsa@aur.archlinux.org>
+
+ * Updated to newer version - 0.9.5
+
diff --git a/abs/core/tilda/tilda.install b/abs/core/tilda/tilda.install
deleted file mode 100644
index 42bc9eb..0000000
--- a/abs/core/tilda/tilda.install
+++ /dev/null
@@ -1,44 +0,0 @@
-# This is a default template for a post-install scriptlet. You can
-# remove any functions you don't need (and this header).
-
-# arg 1: the new package version
-pre_install() {
- /bin/true
-}
-
-# arg 1: the new package version
-post_install() {
- MHOME=`cat /etc/passwd | grep "mythtv" | cut -d":" -f6`
- if [ ! -e $MHOME/.keylaunchrc ]
- then
- echo "setting symlink for keylaunch"
- ln -s /etc/keylaunchrc $MHOME/.keylaunchrc
-fi
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- /bin/true
-
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install
-}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-# arg 1: the old package version
-post_remove() {
- /bin/true
-}
-
-op=$1
-shift
-$op $*
diff --git a/abs/core/tilda/tilda_hide.patch b/abs/core/tilda/tilda_hide.patch
new file mode 100644
index 0000000..19d2869
--- /dev/null
+++ b/abs/core/tilda/tilda_hide.patch
@@ -0,0 +1,35 @@
+--- src/tilda.c.orig 2012-12-10 13:11:23.336581090 -0600
++++ src/tilda.c 2012-12-10 13:44:31.543784376 -0600
+@@ -582,11 +582,11 @@
+ if (access (tw->config_file, R_OK) == -1)
+ {
+ /* We probably need a default key, too ... */
+- gchar *default_key = g_strdup_printf ("F%d", tw->instance+1);
++ gchar *default_key = g_strdup_printf ("F%d", tw->instance+3);
+ config_setstr ("key", default_key);
+ g_free (default_key);
+
+- need_wizard = TRUE;
++// need_wizard = TRUE;
+ }
+
+ /* Show the wizard if we need to.
+@@ -598,12 +598,12 @@
+ {
+ gint ret = tilda_keygrabber_bind (config_getstr ("key"), tw);
+
+- if (!ret)
+- {
+- /* The key was unbindable, so we need to show the wizard */
+- show_invalid_keybinding_dialog (NULL);
+- wizard (tw);
+- }
++// if (!ret)
++// {
++// /* The key was unbindable, so we need to show the wizard */
++// show_invalid_keybinding_dialog (NULL);
++// wizard (tw);
++// }
+ }
+
+ if (config_getbool ("hidden"))