summaryrefslogtreecommitdiffstats
path: root/abs/core/util-linux
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/util-linux')
-rw-r--r--abs/core/util-linux/PKGBUILD84
-rw-r--r--abs/core/util-linux/mount-segfault-2.19.1.patch84
-rw-r--r--abs/core/util-linux/pam-common6
-rw-r--r--abs/core/util-linux/pam-login7
-rw-r--r--abs/core/util-linux/pam-su9
-rw-r--r--abs/core/util-linux/term_utils-agetty.patch17
-rw-r--r--abs/core/util-linux/util-linux.install21
-rw-r--r--abs/core/util-linux/uuidd.tmpfiles1
8 files changed, 125 insertions, 104 deletions
diff --git a/abs/core/util-linux/PKGBUILD b/abs/core/util-linux/PKGBUILD
index 877e013..857bcc4 100644
--- a/abs/core/util-linux/PKGBUILD
+++ b/abs/core/util-linux/PKGBUILD
@@ -1,38 +1,82 @@
-# $Id: PKGBUILD 123897 2011-05-14 09:14:06Z tpowa $
-# Maintainer:
+# $Id: PKGBUILD 171469 2012-11-17 23:02:13Z allan $
+# Maintainer: Tom Gundersen <teg@jklm.no>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=util-linux
-pkgver=2.19.1
-pkgrel=2
+pkgver=2.22.1
+pkgrel=3
pkgdesc="Miscellaneous system utilities for Linux"
-url="http://userweb.kernel.org/~kzak/util-linux-ng/"
+url="http://www.kernel.org/pub/linux/utils/util-linux/"
arch=('i686' 'x86_64')
groups=('base')
-depends=('bash' 'ncurses>=5.7' 'zlib' 'filesystem')
-replaces=('linux32' 'util-linux-ng')
-conflicts=('linux32' 'util-linux-ng' 'e2fsprogs<1.41.8-2')
-provides=('linux32' "util-linux-ng=${pkgver}")
+depends=('pam' 'shadow' 'coreutils' 'glibc')
+# checkdepends=('bc')
+conflicts=('util-linux-ng' 'eject')
+provides=("util-linux-ng=${pkgver}" 'eject')
license=('GPL2')
options=('!libtool')
-source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.19/${pkgname}-${pkgver}.tar.bz2
- mount-segfault-2.19.1.patch)
-optdepends=('perl: for chkdupexe support')
-md5sums=('3eab06f05163dfa65479c44e5231932c'
- '3247b52f0e4b8044f23f2f7218e2fdea')
+source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.22/${pkgname}-${pkgver}.tar.xz
+ uuidd.tmpfiles
+ pam-login
+ pam-common
+ pam-su)
+backup=(etc/pam.d/chfn
+ etc/pam.d/chsh
+ etc/pam.d/login
+ etc/pam.d/su
+ etc/pam.d/su-l)
+install=util-linux.install
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # fix https://bugs.archlinux.org/task/24261
- patch -Np1 -i ../mount-segfault-2.19.1.patch
- # hardware clock
- sed -e 's%etc/adjtime%var/lib/hwclock/adjtime%' -i hwclock/hwclock.c
- ./configure --enable-arch --enable-write --enable-raw --disable-wall --enable-partx
+
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib \
+ --localstatedir=/run \
+ --enable-fs-paths-extra=/usr/bin:/usr/sbin \
+ --enable-raw \
+ --enable-vipw \
+ --enable-newgrp \
+ --enable-chfn-chsh \
+ --enable-write \
+ --enable-mesg \
+ --enable-socket-activation
+
+# --enable-reset \ # part of ncurses
+# --enable-line \ # not part of any package
+# --enable-last \ # not compat
+
make
}
+#check() {
+# fails for some reason in chroot, works outside
+# make -C "$pkgname-$pkgver" check
+#}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- install -dm755 "${pkgdir}/var/lib/hwclock"
+
make DESTDIR="${pkgdir}" install
+
+ cd "${pkgdir}"
+
+ # setuid chfn and chsh
+ chmod 4755 "$pkgdir"/usr/bin/{newgrp,ch{sh,fn}}
+
+ # install PAM files for login-utils
+ install -Dm644 "$srcdir/pam-common" "$pkgdir/etc/pam.d/chfn"
+ install -m644 "$srcdir/pam-common" "$pkgdir/etc/pam.d/chsh"
+ install -m644 "$srcdir/pam-login" "$pkgdir/etc/pam.d/login"
+ install -m644 "$srcdir/pam-su" "${pkgdir}/etc/pam.d/su"
+ install -m644 "$srcdir/pam-su" "${pkgdir}/etc/pam.d/su-l"
+
+ # include tmpfiles fragment for uuidd
+ # TODO(dreisner): offer this upstream?
+ install -Dm644 "$srcdir/uuidd.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/uuidd.conf"
}
+md5sums=('730cf9932531ed09b53a04ca30fcb4c9'
+ 'a39554bfd65cccfd8254bb46922f4a67'
+ '4368b3f98abd8a32662e094c54e7f9b1'
+ 'a31374fef2cba0ca34dfc7078e2969e4'
+ 'fa85e5cce5d723275b14365ba71a8aad')
diff --git a/abs/core/util-linux/mount-segfault-2.19.1.patch b/abs/core/util-linux/mount-segfault-2.19.1.patch
deleted file mode 100644
index 7bcb3bc..0000000
--- a/abs/core/util-linux/mount-segfault-2.19.1.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From f53edda83ebcfd7015c3f35196d6cbd7bc2d8369 Mon Sep 17 00:00:00 2001
-From: Karel Zak <kzak@redhat.com>
-Date: Wed, 11 May 2011 16:57:27 +0200
-Subject: [PATCH] mount: -a segfaults when 4th field is omitted (mount
- options)
-
- # echo 'tmpd /tmp/x tmpfs' >> /etc/fstab
- # mkdir /tmp/x
- # mount -a
- segfault
-
-Reported-by: Mike Frysinger <vapier@gentoo.org>
-Signed-off-by: Karel Zak <kzak@redhat.com>
----
- mount/mount.c | 8 +++++---
- mount/mount_mntent.c | 5 +++--
- mount/sundries.c | 2 ++
- 3 files changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/mount/mount.c b/mount/mount.c
-index ba71149..29963c2 100644
---- a/mount/mount.c
-+++ b/mount/mount.c
-@@ -1163,7 +1163,9 @@ is_mounted_same_loopfile(const char *node0, const char *loopfile, unsigned long
- res = loopfile_used_with((char *) mnt->m.mnt_fsname,
- loopfile, offset);
-
-- else if ((p = strstr(mnt->m.mnt_opts, "loop="))) {
-+ else if (mnt->m.mnt_opts &&
-+ (p = strstr(mnt->m.mnt_opts, "loop=")))
-+ {
- char *dev = xstrdup(p+5);
- if ((p = strchr(dev, ',')))
- *p = '\0';
-@@ -2052,8 +2054,8 @@ is_fstab_entry_mounted(struct mntentchn *mc, int verbose)
- goto yes;
-
- /* extra care for loop devices */
-- if ((strstr(mc->m.mnt_opts, "loop=") ||
-- (stat(mc->m.mnt_fsname, &st) == 0 && S_ISREG(st.st_mode)))) {
-+ if ((mc->m.mnt_opts && strstr(mc->m.mnt_opts, "loop=")) ||
-+ (stat(mc->m.mnt_fsname, &st) == 0 && S_ISREG(st.st_mode))) {
-
- char *p = get_option_value(mc->m.mnt_opts, "offset=");
- uintmax_t offset = 0;
-diff --git a/mount/mount_mntent.c b/mount/mount_mntent.c
-index d90def3..f42c0ad 100644
---- a/mount/mount_mntent.c
-+++ b/mount/mount_mntent.c
-@@ -70,7 +70,7 @@ my_addmntent (mntFILE *mfp, struct my_mntent *mnt) {
- m1 = mangle(mnt->mnt_fsname);
- m2 = mangle(mnt->mnt_dir);
- m3 = mangle(mnt->mnt_type);
-- m4 = mangle(mnt->mnt_opts);
-+ m4 = mnt->mnt_opts ? mangle(mnt->mnt_opts) : "rw";
-
- res = fprintf (mfp->mntent_fp, "%s %s %s %s %d %d\n",
- m1, m2, m3, m4, mnt->mnt_freq, mnt->mnt_passno);
-@@ -78,7 +78,8 @@ my_addmntent (mntFILE *mfp, struct my_mntent *mnt) {
- free(m1);
- free(m2);
- free(m3);
-- free(m4);
-+ if (mnt->mnt_opts)
-+ free(m4);
- return (res < 0) ? 1 : 0;
- }
-
-diff --git a/mount/sundries.c b/mount/sundries.c
-index ae4501a..2dec37f 100644
---- a/mount/sundries.c
-+++ b/mount/sundries.c
-@@ -217,6 +217,8 @@ matching_opts (const char *options, const char *test_opts) {
-
- if (test_opts == NULL)
- return 1;
-+ if (options == NULL)
-+ options = "";
-
- len = strlen(test_opts);
- q = alloca(len+1);
---
-1.7.5.1
-
diff --git a/abs/core/util-linux/pam-common b/abs/core/util-linux/pam-common
new file mode 100644
index 0000000..a7bf8a4
--- /dev/null
+++ b/abs/core/util-linux/pam-common
@@ -0,0 +1,6 @@
+#%PAM-1.0
+auth sufficient pam_rootok.so
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
+password required pam_permit.so
diff --git a/abs/core/util-linux/pam-login b/abs/core/util-linux/pam-login
new file mode 100644
index 0000000..1960d94
--- /dev/null
+++ b/abs/core/util-linux/pam-login
@@ -0,0 +1,7 @@
+#%PAM-1.0
+
+auth required pam_securetty.so
+auth requisite pam_nologin.so
+auth include system-local-login
+account include system-local-login
+session include system-local-login
diff --git a/abs/core/util-linux/pam-su b/abs/core/util-linux/pam-su
new file mode 100644
index 0000000..cf15f40
--- /dev/null
+++ b/abs/core/util-linux/pam-su
@@ -0,0 +1,9 @@
+#%PAM-1.0
+auth sufficient pam_rootok.so
+# Uncomment the following line to implicitly trust users in the "wheel" group.
+#auth sufficient pam_wheel.so trust use_uid
+# Uncomment the following line to require a user to be in the "wheel" group.
+#auth required pam_wheel.so use_uid
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/abs/core/util-linux/term_utils-agetty.patch b/abs/core/util-linux/term_utils-agetty.patch
new file mode 100644
index 0000000..f0b37b3
--- /dev/null
+++ b/abs/core/util-linux/term_utils-agetty.patch
@@ -0,0 +1,17 @@
+--- term-utils/agetty.orig 2012-08-02 19:44:36.234757299 +0000
++++ term-utils/agetty.c 2012-08-02 19:47:15.464752505 +0000
+@@ -961,12 +961,12 @@
+ */
+
+ if ((fcntl(STDIN_FILENO, F_GETFL, 0) & O_RDWR) != O_RDWR)
+- log_err(_("%s: not open for read/write"), tty);
++ log_warn(_("%s: not open for read/write"), tty);
+
+ }
+
+ if (tcsetpgrp(STDIN_FILENO, pid))
+- log_err("/dev/%s: cannot set process group: %m", tty);
++ log_warn("/dev/%s: cannot set process group: %m", tty);
+
+ /* Get rid of the present outputs. */
+ close(STDOUT_FILENO);
diff --git a/abs/core/util-linux/util-linux.install b/abs/core/util-linux/util-linux.install
new file mode 100644
index 0000000..4c0bb10
--- /dev/null
+++ b/abs/core/util-linux/util-linux.install
@@ -0,0 +1,21 @@
+post_install() {
+ # we don't want use systemd-tmpfiles here because
+ # the package dependency would create a circular dep.
+ if [ ! -d run/uuidd ]; then
+ # refer to uid/gid by number to avoid dependency on filesystem
+ install -o 68 -g 68 -dm755 run/uuidd
+ fi
+}
+
+post_upgrade() {
+ if [ "$(vercmp $2 2.21.2-4)" -lt 0 ]; then
+ if [ -f /var/lib/hwclock/adjtime ]; then
+ mv /var/lib/hwclock/adjtime /etc/adjtime
+ fi
+ if [ -d /var/lib/hwclock ]; then
+ rmdir /var/lib/hwclock
+ fi
+ fi
+
+ post_install
+}
diff --git a/abs/core/util-linux/uuidd.tmpfiles b/abs/core/util-linux/uuidd.tmpfiles
new file mode 100644
index 0000000..b059cfe
--- /dev/null
+++ b/abs/core/util-linux/uuidd.tmpfiles
@@ -0,0 +1 @@
+d /run/uuidd 0755 uuidd uuidd