summaryrefslogtreecommitdiffstats
path: root/abs/core/windowmaker/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/windowmaker/PKGBUILD')
-rw-r--r--abs/core/windowmaker/PKGBUILD51
1 files changed, 36 insertions, 15 deletions
diff --git a/abs/core/windowmaker/PKGBUILD b/abs/core/windowmaker/PKGBUILD
index 61c2b65..2c12ff1 100644
--- a/abs/core/windowmaker/PKGBUILD
+++ b/abs/core/windowmaker/PKGBUILD
@@ -1,22 +1,45 @@
-# $Id: PKGBUILD 159727 2012-05-26 10:06:04Z daniel $
+# $Id$
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
pkgname=windowmaker
-pkgver=0.95.4
-pkgrel=5
+pkgver=0.95.6
+pkgrel=1
pkgdesc="An X11 window manager with a NEXTSTEP look and feel"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.windowmaker.org/"
license=('GPL' 'custom')
depends=('libxinerama' 'libxrandr' 'libxmu' 'libpng' 'libxpm' 'libxft' 'libtiff' 'giflib')
-options=('!libtool')
-source=(http://windowmaker.org/pub/source/release/WindowMaker-$pkgver.tar.gz wmaker.desktop)
-#source=(WindowMaker-$pkgver.tar.gz wmaker.desktop)
+source=(http://windowmaker.org/pub/source/release/WindowMaker-$pkgver.tar.gz
+ wmaker.desktop
+ giflib_510.diff)
install=wmaker.install
+md5sums=('5b3cf9e6cd1f4066ffa5f2f22c25aee3'
+ '2fba97bebfd691836b92b8f0db79ff13'
+ 'ac51e22a9d6a8d653cfa8cbcc6fea96e')
+
+prepare() {
+ cd WindowMaker-$pkgver
+ #patch -Np0 -i ../wm-giflib.patch
+
+ # patch taken from NetBSD
+ patch -Np0 -i ../giflib_510.diff
+
+ autoreconf -fi
+
+ # fix some paths FS#3080 - ckeck also Gentoo ebuild
+ for file in WindowMaker/*menu* util/wmgenmenu.c; do
+ if [[ -r $file ]] ; then
+ sed -i -e "s:/usr/local/GNUstep/Applications/WPrefs.app:/usr/lib/GNUstep/Applications/WPrefs.app:g;" "$file"
+ sed -i -e "s:/usr/local/share/WindowMaker:/usr/share/WindowMaker:g;" "$file"
+ sed -i -e "s:/opt/share/WindowMaker:/usr/share/WindowMaker:g;" "$file"
+ fi;
+ done;
+}
+
build() {
- cd $srcdir/WindowMaker-$pkgver
+ cd WindowMaker-$pkgver
[ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
-# sh ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --enable-xinerama \
--with-nlsdir=/usr/share/locale --with-gnustepdir=/usr/lib/GNUstep \
--enable-usermenu --enable-modelock --enable-xrandr
@@ -24,12 +47,10 @@ build() {
}
package() {
- cd $srcdir/WindowMaker-$pkgver
+ cd WindowMaker-$pkgver
- make DESTDIR=$pkgdir install
- install -D -m644 COPYING.WTFPL $pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL
- install -D -m644 $srcdir/wmaker.desktop $pkgdir/usr/share/xsessions/wmaker.desktop
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING.WTFPL "$pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL"
+ install -D -m644 ../wmaker.desktop "$pkgdir/usr/share/xsessions/wmaker.desktop"
}
-md5sums=('81d7138ea89618b2c7093f6ecff7d603'
- '2fba97bebfd691836b92b8f0db79ff13')